Emails are being sent as localhost.localdomain


(Cédric Poottaren) #1

Hello,

So this is the first time I’m trying to install discourse. When I try to complete installations by verifying my email address I notice that emails from discourse are being sent as localhost.localdomain.

Since I’ve configured postfix not to allow unknown host, discourse emails dont parse through.

Is there a way I can tell discourse to use another ‘send from address’?

Thanks for your time.


(Michael Friedrich) #2

This sounds like your HOSTNAME setting was set to localhost, or isn’t an FQDN in app.yml. How exactly did you configure those settings?

Is that a local postfix mta on the same host where Discourse is running in the container, or a remote one as mail relay?

Edit: Google pointed me here again:


(Cédric Poottaren) #3

Hello,

I’ve rechecked the app.yml file and the HOSTNAME is properly configured with a FQDN.
Yes, the server hosting Discourse is also my email server running Postfix as MTA.

I finally have my Discourse instance working by abandoning the idea of using my own mail server and switched over to mailgun instead.

Thanks for the support.


(Joshua Rosenfeld) #4

This topic was automatically closed after 29 hours. New replies are no longer allowed.