Emails will not send: Job exception: getaddrinfo: Name or service not known


(Harry) #1

Backtrace:

/usr/local/lib/ruby/2.0.0/net/smtp.rb:541:in `initialize'
/usr/local/lib/ruby/2.0.0/net/smtp.rb:541:in `open'
/usr/local/lib/ruby/2.0.0/net/smtp.rb:541:in `tcp_socket'
/usr/local/lib/ruby/2.0.0/net/smtp.rb:551:in `block in do_start'
/usr/local/lib/ruby/2.0.0/timeout.rb:66:in `timeout'
/usr/local/lib/ruby/2.0.0/net/smtp.rb:550:in `do_start'
/usr/local/lib/ruby/2.0.0/net/smtp.rb:520:in `start'
/var/www/discourse/vendor/bundle/ruby/2.0.0/gems/mail-2.6.3/lib/mail/network/delivery_methods/smtp.rb:112:in `deliver!'
/var/www/discourse/vendor/bundle/ruby/2.0.0/gems/mail-2.6.3/lib/mail/message.rb:2141:in `do_delivery'
/var/www/discourse/vendor/bundle/ruby/2.0.0/gems/mail-2.6.3/lib/mail/message.rb:236:in `block in deliver'
/var/www/discourse/vendor/bundle/ruby/2.0.0/gems/actionmailer-4.2.4/lib/action_mailer/base.rb:543:in `block in deliver_mail'
/var/www/discourse/vendor/bundle/ruby/2.0.0/gems/activesupport-4.2.4/lib/active_support/notifications.rb:164:in `block in instrument'
/var/www/discourse/vendor/bundle/ruby/2.0.0/gems/activesupport-4.2.4/lib/active_support/notifications/instrumenter.rb:20:in `instrument'
/var/www/discourse/vendor/bundle/ruby/2.0.0/gems/activesupport-4.2.4/lib/active_support/notifications.rb:164:in `instrument'
/var/www/discourse/vendor/bundle/ruby/2.0.0/gems/actionmailer-4.2.4/lib/action_mailer/base.rb:541:in `deliver_mail'
/var/www/discourse/vendor/bundle/ruby/2.0.0/gems/mail-2.6.3/lib/mail/message.rb:236:in `deliver'
/var/www/discourse/vendor/bundle/ruby/2.0.0/gems/actionmailer-4.2.4/lib/action_mailer/message_delivery.rb:85:in `deliver_now'
/var/www/discourse/lib/email/sender.rb:131:in `send'
/var/www/discourse/app/jobs/regular/user_email.rb:65:in `execute'
/var/www/discourse/app/jobs/base.rb:154:in `block (2 levels) in perform'

(Rafael dos Santos Silva) #2

Do you use proxy / akka HTTP_PROXY != nil ?


(Harry) #3

Not a clue, never touched it nor have I seen it in app.yml


(Kane York) #4

This means that Discourse can’t resolve the DNS of your email server. What are you using for email sending?


(Harry) #5

I’m using sparkpost.