Embedded forum links are not refreshing the browser after click


(Michael Jonker) #1

On the image below, link No.1 is working correctly.
Link No.2 updates the url bar, but the page does not refresh until it is manually reloaded from the browser.


(Bill Ayakatubby) #2

What browser/operating system? What version of Discourse?


(Michael Jonker) #3

Sorry!

Discourse version 0.9.8.3
Ubuntu 12.10
Both Firefox and Chromium display this behaviour.

Checked on Mac OS - Firefox as well. Same behaviour.


(Michael Jonker) #4

You can test it here:

https://forum.limerickspring.com/t/our-local-authority-where-does-the-power-lie/197


(Bill Ayakatubby) #5

Yep, verified on Chrome 32, Win 8.1 desktop.


(ABiS) #6

yes, I experience both the same issue as @citkane and also in a slightly different one: I linked to /faq in a topic and that link behaves the same way (updated the URL in the browser bar but doesn’t actually take you to the FAQ page).

So I’d say it’s any internal link, being it another topic or not


(Bill Ayakatubby) #7

@abis, what version of Discourse are you running?

Have either of you tried updating to latest - i.e., even beyond the most recent numbered release? The devs have said in the past that the numbered releases can lag significantly behind during this beta period.


(ABiS) #8

I’m on 0.9.8.3, I’ll try and update to latest (first time I’ll try since installing discourse last week) and report back.

Thanks!


(Michael Jonker) #9

I am on 0.9.8.3 ‘Master’ from GIT installed as per:
https://github.com/discourse/discourse/blob/master/docs/INSTALL-ubuntu.md

I am not confident enough to go ahead of that.


(ABiS) #10

I’ve just upgraded to “bleeding edge” (though the dashboard still says 0.9.8.3?!?!) and I confirm the internal links issue seems to be solved.


(Michael Jonker) #11

Is this done by:

git checkout bleeding-edge ?

Anybody having any major issues with bleeding-edge? Advice Please.


(ABiS) #12

there is a bit of confusion in the naming :smile:

I followed the Ubuntu guide and in the ‘Updating Discourse’ paragraph it says:

git checkout master
’# To run on the latest numbered release instead of bleeding-edge:
#git checkout latest-release

so I called it bleeding-edge, but it’s master


(Michael Jonker) #13

I am on ‘Master’, but the problem persists for me.


(ABiS) #14

if you are absolutely sure you didn’t follow this bit in the installation giude:

‘# To run on the most recent numbered release instead of bleeding-edge:
#git checkout latest-release

when you installed it (I had to check my history because I wasn’t sure if I had) then 1) it’s weird and 2) maybe just restart bluepill (talking out of my @$$ here)?


(Michael Jonker) #15

If I remember correctly, I did the initial install on ‘checkout latest-release’, but all the subsequent upgrades on ‘checkout master’

Am I doing something wrong?

Ran a bluepill restart earlier today already.


(ABiS) #16

sorry, I’m too new to discourse to help


(ABiS) #17

in the mean time I can tell you everything seems to work fine after the upgrade. The only funny thing I can see at the moment is that most of the dates in the ‘New Topics’ and ‘New Posts’ columns under /categories are way off: some say 3 week, others 4 or even 7 month when they are all like 1 or 2 days old :smile:

But the dates are correct everywhere else


(Jeff Atwood) #18

@neil can you have a look here?


(Neil Lalonde) #19

This sounds similar to the other problem you were seeing where topics in sub-categories were not showing on the /categories page. Those topics and the counts are both updated periodically by scheduled jobs (PeriodicalUpdates and CategoryStats). In that topic you said you upgraded and then the first problem was fixed.

I’m seeing this problem on other sites, but can’t reproduce it locally. So I think something is messed up with the scheduled jobs. I’m investigating.


(ABiS) #20

thanks, let me know if I can provide any useful info