Emojis Not Displaying / Old Avatar Styles


(Anthony Giovannetti) #1

Relating to the original issue that I filed at: Discourse WordPress Plugin: Emoji's do not properly display

We are currently on the latest version of Wordpress with the latest version of the plugin. (0.5.5).

You can see that emojis are not displaying correctly.

The Plugin:

EDIT: Just as I was finishing this post, the emoji started to correctly display. Emojis for older posts are still not displaying correctly, but this post is.

Older URLS: http://stimhack.com/plugins/emoji/images/stuck_out_tongue.png
Example page with non functioning emoji: Fear and Loathing Set Review & Playtesting Guide - StimHack

Now working URL: http://forum.stimhack.com/plugins/emoji/images/smile.png
Example Page with functioning emoji: Uncle’s Games, Bellevue S.C. Draft Tournament – 2nd Place Report - StimHack


Additionally, the avatars are all the older style and not the nicer looking square style that is currently used. Could we have screwed something up in upgrading to the newer version of the plugin? @sam


Wordpress not displaying Avatars
(Anthony Giovannetti) #2

We just tried re-installing the plugin today, and the avatar styles are still incorrect. Anything we should be looking at to actually resolve this annoying issue?


(Sam Saffron) #3

Rebake old posts

In docker run rake --tasks to see the task list available


(Anthony Giovannetti) #4

We have switched over to https://www.discoursehosting.com/ and migrated everything over. Unfortunately we are still seeing both the avatar style problem and:
[Fixed] WordPress Plugin: Posts incorrectly always publish to discourse

@michaeld anyway you can do what @sam suggested above?


(Michael - DiscourseHosting.com) #5

Yes - we’ll address this later this week. This might have to do with a previous update gone bad at your old host. Some assets weren’t moved over correctly to the Bitnami installation.


(blaumeer) #6

Not sure if I should revive this topic, but it’s the nearest to what I am experiencing now.

Latest D., latest wp-discourse plugin, emojis don’t display and show up as their literal instead, such as

wrench smiley stuck_out_tongue sunny

search “wrench wrench wrench” in the comment section:

see: stuck_out_tongue

The above setup is on 2 different domains (.com for the wp site, .it for the Discourse instance), and https. I have the same bevavior on the same domain, and plain http.
http://nazioneindiana.bamaulion.net/2015/aenean-euismod-luctus-dui/

The only peculiar thing about my setup is a Nginx reverse proxy in front of the D. instance. WP Super Cache is disabled in the above second site.

Any idea on what may be the root of the issue?


(blaumeer) #7

Well, I fixed it: the emoji icons are pulled from /images on the wordpress site, which obviously does not exist, so I had to add a redirect in the wordpress site .htaccess:

Redirect 301 /images https://discourse.example.com/images

Thanks to a friend to pointed me the obvious issue.


(Ben Word) #8

Here’s a fix for the plugin so you don’t have to do that:

https://github.com/discourse/wp-discourse/pull/114


(pjv) #9

Here’s a fix for the fix if your discourse instance is already supplying absolute URLs like mine was. This should make relative URLs absolute (thanks to @benword) but leave already absolute URLs alone.

https://github.com/discourse/wp-discourse/pull/131