Enable SPDY on meta?


(Kane York) #1

I see that SPDY is not enabled here on Meta, even though the provided web.ssl.template.yml file sets it up. Any reasons it’s not?


(Sam Saffron) #2

Mainly that @supermathie has not got around to it yet, we don’t terminate SSL in the containers, we do it externally in haproxy.


(Kane York) #3

Ah, that would explain it then. Okay! :slight_smile:

SPDY Indicator extension: HTTP/2 and SPDY indicator - Chrome Web Store


(Jeff Atwood) #4

Would like to see spdy here @supermathie!


(Michael Brown) #5

Oh blame me, eh? :tongue:

To do so we would need to stop doing the SSL termination at haproxy.

Unfortunate! But once HTTP2 (HTTP3?) is released, we should see support in haproxy.


(Jeff Atwood) #6

Hmm.

And when will that be?


(Kane York) #7

Sometime around when we get HTMLBars, I think

/s


(Michael Brown) #8

Latest estimates have that at six-to-eight weeks.


(Rafael dos Santos Silva) #9

Hi guys,

When browsing on mobile, and looking for emojis, I noticed that SPDY isn’t enabled.

Since you guys already use Nginx & HTTPS it’s just one line, and after next Nginx update it becomes HTTP2.

Is it because CDN doesn’t play along well?

Go HTTP2 Test
Akamai


(Sam Saffron) #10

Yeah, see:


(Rafael dos Santos Silva) #11

They probably will get after nginx add support in the next version. Soon enough.

Thanks!


(Sam Saffron) #12

Unlikely, they need Varnish to support it or have some mechanism to front Varnish with HTTP/2 … NGINX is unrelated, not part of Fastly’s stack as far as I can tell.


(Rafael dos Santos Silva) #13

Oh I see. Cloudfare is the one heavy on Nginx, my mistake.