Enabled HTTPS, how do i disable it


(Deepak) #1

Hi,

I am running a discourse version for a small forum I run.

I recently did some stupidity and enabled “force https” without any reading or any associated work I needed to do.

I tried disabling it, and get the error “Sorry, an error has occurred.”

This is causing an issue on the forum which I am sure you guys would know of.

How do I bail out of this situation?

My discourse instance is v1.7.0.beta10 +82

Thanks, all your help is appreciated.

Regards


(Jay Pfaffman) #2

What is the problem makes you want to disable it? Oh. Wait. Are you saying that you turned on force https but your instance doesn’t support https? (It should arguably be harder to do that.) If that’s the case, then the ways to turn off that setting are more complicated than turning on https for your server.

You should upgrade anyway. Log in to your server and run discourse-setup. If you don’t want to, I will.


(Deepak) #3

I tried updating the docker, when I click on update it does not initiate or nothing happens.

Have tried this on GUI


(Joshua Rosenfeld) #4

@dchiniwal, how (and when) did you initially install Discourse? Did you follow the official guide and install on Digital Ocean?

If so, SSH into your server and run the following commands:

cd /var/discourse
git pull
./discourse-setup

You can keep all the defaults it suggests, then follow the instructions for setting up Let’s Encrypt. You can get more details (and manual instructions) at Setting up Let’s Encrypt.


(Jay Pfaffman) #5

But if you do this, all that is required to set up let’s encrypt is to type your email address. Or, really, any email addr ss, if you don’t want to know if something goes wrong with certifate renewal.