# "Ensure sidekiq is running." when it is definitely running

**URL:** <https://meta.discourse.org/t/ensure-sidekiq-is-running-when-it-is-definitely-running/33936>\
**Category:** Self-hosting\
**Created:** [2015年九月30日 13:31 UTC](https://meta.discourse.org/t/ensure-sidekiq-is-running-when-it-is-definitely-running/33936 "2015-09-30T13:31:09Z")\
**Posts on this page:** 1\
**Showing post:** 5

<div class="post-metadata">

**Author:** ![clay](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/clay/32/102156_2.png) [@clay](https://meta.discourse.org/u/clay)\
**Post date:** [2015年九月30日 14:02 UTC](https://meta.discourse.org/t/ensure-sidekiq-is-running-when-it-is-definitely-running/33936/5 "2015-09-30T14:02:49Z")

</div>

Oops. Wrong link. I meant this problem:

> [@Docker problem after machine restart](https://meta.discourse.org/t/docker-problem-after-machine-restart/33604):
>
> I had to reboot the machine I have Discourse running on to replace a bad graphics card. However, Discourse won’t restart. When I try ./launcher restart app from within /var/discourse, I see: clay@machine:/var/discourse$ ./launcher restart app + /usr/bin/docker stop -t 10 app app starting up existing container + /usr/bin/docker start app Error response from daemon: Cannot start container app: Bind for 0.0.0.0:9999 failed: port is already allocated Error: failed to start containers: [app] When …

---

_[View the full topic](https://meta.discourse.org/t/ensure-sidekiq-is-running-when-it-is-definitely-running/33936)._
