Entering new topics on Mac placing me scrolled down


(Brentley Jones) #1

I come back from a weekend of not reading topics here, look at all those new topics! (blue asterisks) Reading some I have found a bug though.

When I click on some and I end up on the “Suggested Topics” or half way down a post. It seems that the scroll position from the Topic Page is being maintained when I go to a new topic. Already visited topics have the same issue, they initially load scrolled down, but after that they snap to the last post read.


(Jeff Atwood) #2

Ok so the repro is to scroll down on the topic list, then enter a new unread topic? And you end up somewhere other than at the top of the new topic?

Also what browser and version?


(Brentley Jones) #3

Correct.

OS X, Chrome Version 29.0.1547.57.


(Kevin P. Fleming) #4

Same behavior here, also OSX and Chrome 29.0.1547.65.


(Sam Saffron) #5

I notice this happens to me on OSX quite often but not at all in Windows. @eviltrout can you confirm that happens to you on chrome?


(Robin Ward) #6

This is a really weird one. @Neil can reproduce it on the same OSX and Chrome version as me (10.8.4 and 29.0.1547.65), but I can’t seem to do it.

I’ve tried on meta and locally. I’ve tried incognito and not. I’ve cleared my cache. Any other ideas?


(Brentley Jones) #7

Related?: When I enter a topic, read/scroll down some, then hit back, I sometimes get scrolled to the top of the topic before the topic list appears.

Edit: happens even without scrolling. I think it puts me back at where it was before it snaps me to the correct post.


(Sam Saffron) #8

I suggest a divining rod, I would offer you one, but in Australia we use divining snakes.


(Brentley Jones) #9

Still happening. Makes reading new topics a pain. End up at a random spot in the stream and I have to manually scroll up. Also, for already read topics the visual jar of seeing the suggested topics box then a flash to the real post… not fun.


(MaMu) #10

I have the same problem with Opera 16 on Mac OS X 10.7.5. It’s really annoying!


(Jeff Atwood) #11

So far as we can tell this is OS X specific but we cannot always repro it.


(Brentley Jones) #12

This is preventing me from updating my instance. I know, it’s a petty bug, but it annoys the crap out of me.


(Jeff Atwood) #13

This is still happening for you on meta? We do not have a lot of reports of this, which is surprising since plenty of Mac users and multiple team members use Macs. @zogstrip can you repro?


(Michael John Kirk) #14

I’m getting it on Chrome: Version 31.0.1650.8 beta


(Jeff Atwood) #15

Also on Mac I presume? I know this is already an issue reported on non-beta browsers too by some folks, but for the record we do not support beta browsers.


(Régis Hanol) #16

Tried a bunch of time with latest Chrome (30.0.1599.101) on OS X and can’t repro.


(Jeff Atwood) #17

Hmm, @mkirk, @ajarn and others who can repro this on OS X

  • are you running any extensions or plugins in Chrome?
  • is it 100% repeatable for you?
  • can you try in Chrome Incognito mode?
  • does it happen in other browsers for you?

I have definitely never seen this in Windows, on any browser. It seems very Mac specific for some strange reason.


(Brentley Jones) #18
  • No extensions or plugins
  • 100% repeatable (you have to have the topic page scrolled down a bit, it preserves the scroll when it changes to the new view)
  • Incognito still happens
  • Does not happen in Safari. Also tested Chrome Windows and it doesn’t happen there either.

(Sam Saffron) #19

I used to be able to repro this on my mac book pro, but am unable to anymore as of 30.0.1599.101 , this is odd cause @mkirk can repro on a later version.

Regardless this is a subtle timing issue, we are fighting with the browser with regard to scroll position.

Can you double confirm you are on 30.0.1599.101 ?


(Brentley Jones) #20

Version 30.0.1599.101

Google Chrome is up to date.