Error 500 when trying to connect to Twitter in user preferences


(Scot) #1

As a user I am in preferences and under associated accounts I click on “connect” for twitter and I get this error:

I checked my twitter settings for consumer key and consumer secret and they appear to be correct. I am not sure what the problem might be or where to start in trying to fix it. Any help would be appreciated.

Thank you,
Scot


(Jay Pfaffman) #2

My best guess is that you gave twitter the wrong callback URL.

You can check /var/discourse/shared/standalone/logs/rails/production.log for hints.


(Scot) #3

Thanks Jay,

I see I accidentally put:

http://forum.example.com/auth/twitter/callback

and forgot to change it. I just changed it to the correct domain name but still having the same issue. I am not sure if it takes a while for the change to take effect or if there is something else causing the problem.


(Jay Pfaffman) #4

You exposed the actual URL earlier, so there’s no reason to hide it now. :wink:

I believe that changing the callback should take effect immediately. Perhaps you didn’t actually click the “really, really save it” button.

What do you see in the rails logs?


(Scot) #5

LOL - Oh well. Maybe there are sober vegans on here that will come check it out.

I don’t even know how to check the logs. I know as much as I have been able to google and figure out on this forum. However, I realized the call back url I used did not have the https so I fixed that and it worked!

Thanks for your help and thanks again for doing my original install :slight_smile:

-Scot


(Jay Pfaffman) #6

There’s very rarely not a reason to share your URL. And maybe there are some sober vegans here. You just don’t know.

Yeah. Well, I do. And logged in to your server and was checking and then I tried it, and, well, it’s working now.

You’re welcome. Just don’t tell anyone that I give free support.