Error 502 on moves

Hi everyone, we need some help over at the forum and after reading the topics in here I couldn’t find any definitive answers.

We have an ongoing issue with the 502 error when we move posts from and to large threads (above 5000 posts).

I have been, over the last few days, moving stuff around to see if there is a pattern or indeed randomness to the issue but it does come down to the size of both the threads and not the amount of posts selected. This leads me to the conclusion that its a memory issue and we may need to upgrade our package but the faint off chance that its a known bug, I’d like to hear about it.

1 Like

Looks like there’s a few non-standard (but very popular!) plugins including Babble, so it may be possible that one of those is causing an issue with high post count.

Without any specific logs, it’ll be impossible to get to the bottom of it though - if it’s possible you or another staff member has an account to /logs that would give a much better clue as to what’s the root cause is.


I am so glad you asked because I do indeed have a staff member that is literally champing at the bit to get involved.

I give you the architect of esk8 news, the veritable maestro of prose, the one, the only

Bill Gordon


Take the stage.

maybe ask Damon?

1 Like

If you were explaining this to a common house cat, where might that feline find such a thing?

1 Like

I just disabled all plugins except “who’s online”, so will report back if that helps. Glad to have smart folks helping out on this.

1 Like

So to clarify the high post count is what is causing the issue? This is a try out to reduce our post count read?

Do we need more memory?


View the logs here:

Uncheck debug/warnings, and try to move a problematic post. You should get an error message when that happens explaining a bit more as to why you’re getting the 502.


We will get right on that. Much appreciated.

So, for anyone playing along at home, it appears that @featheredtoast hit the nail on the head with the plug-ins causing the issue.

Disabled the following plugins (all together, unfortunately) and haven’t gotten a 502 since.

It’s a babble issue most likely.

1 Like