Error after rebuilding the launcher


(Pad Pors) #1

I have rebuild our forum, and got this error at the last point of rebuilding (when it is telling me redis is shut-downing, and bye bye) :

Error response from daemon: Untar re-exec error: exit status 1: output: write /var/www/discourse/vendor/bundle/ruby/2.3.0/gems/listen-0.7.3/lib/listen/directory_record.rb: no space left on device

this means I have lack of space on the host, but then when i look at the host-space it’s something like this:

and

is the problem no-space problem or can anyone help me with this please?

two weeks ago i could rebuild the forum without problem, but i can’t do this now. and our forum has not evolved that much during this 2 weeks. so i don’t suppose anything should happen :frowning: !


#2

Did you launch a cleanup ?

cd /var/discourse
./launcher cleanup app

With little disk space, you have to use this command after a rebuild


(Pad Pors) #3

thanks , and yes, have already tried

./launcher cleanup app 
sudo apt-get autoremove
sudo apt-get autoclean

any clue what else i may remove for the moment? since the forum is down .


#4

I don’t know the command for cleaning the logs, it can help get trough the rebuild


(Pad Pors) #5

couldn’t find the log path either. tried searching this forum as well as the paths.

any other suggestion? thanks in advance


(Pad Pors) #6

to save the launch, i just removed some of the archived files of old linux-image (var/apt/archive/…). and it worked for the moment!