# Error after restarting the discourse

**URL:** https://meta.discourse.org/t/error-after-restarting-the-discourse/64149
**Category:** Support
**Created:** [June 8, 2017, 4:07am UTC](https://meta.discourse.org/t/error-after-restarting-the-discourse/64149 "2017-06-08T04:07:37Z")
**Posts on this page:** 17
**Page:** 1

<div class="post-metadata">

### Author: ![11145](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/11145/32/119636_2.png) [@11145](https://meta.discourse.org/u/11145)
#### Post date: [June 8, 2017, 4:07am UTC](https://meta.discourse.org/t/error-after-restarting-the-discourse/64149/1 "2017-06-08T04:07:37Z")

</div>

Tell me, what could be the error?  
After the restart, the discourse stopped running.  
Logs can be seen by reference [https://pastebin.com/DzUPNhAT](https://pastebin.com/DzUPNhAT)

---

<div class="post-metadata">

### Author: ![Falco](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/falco/32/179432_2.png) [@Falco](https://meta.discourse.org/u/Falco)
#### Post date: [June 8, 2017, 4:20am UTC](https://meta.discourse.org/t/error-after-restarting-the-discourse/64149/2 "2017-06-08T04:20:12Z")

</div>

Remove the `discourse-rss-poster` plugin and try again.

---

<div class="post-metadata">

### Author: ![robbyoconnor](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/robbyoconnor/32/120330_2.png) [@robbyoconnor](https://meta.discourse.org/u/robbyoconnor)
#### Post date: [June 8, 2017, 4:32am UTC](https://meta.discourse.org/t/error-after-restarting-the-discourse/64149/3 "2017-06-08T04:32:26Z")

</div>

> [@Falco](#):
>
> Remove the discourse-rss-poster plugin and try again.

He’s getting throttled by Rubygems. Where are you hosted?

---

<div class="post-metadata">

### Author: ![11145](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/11145/32/119636_2.png) [@11145](https://meta.discourse.org/u/11145)
#### Post date: [June 8, 2017, 4:37am UTC](https://meta.discourse.org/t/error-after-restarting-the-discourse/64149/4 "2017-06-08T04:37:57Z")

</div>

> [@Falco](#):
>
> discourse-rss-poster

Thanks huge for the help, after removal of a plug-in discourse-rss-poster, discourse has successfully restarted. @LeoMcA what can be problematic with your plugin? You can view?

---

<div class="post-metadata">

### Author: ![robbyoconnor](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/robbyoconnor/32/120330_2.png) [@robbyoconnor](https://meta.discourse.org/u/robbyoconnor)
#### Post date: [June 8, 2017, 4:53am UTC](https://meta.discourse.org/t/error-after-restarting-the-discourse/64149/5 "2017-06-08T04:53:32Z")

</div>

> [@11145](#):
>
> Thanks huge for the help, after removal of a plug-in discourse-rss-poster, discourse has successfully restarted. @LeoMcA what can be problematic with your plugin? You can view?

If you read the errors, you’re being throttled by rubygems. So your issue wasn’t that plugin per se, but that you got throttled.

---

<div class="post-metadata">

### Author: ![11145](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/11145/32/119636_2.png) [@11145](https://meta.discourse.org/u/11145)
#### Post date: [June 8, 2017, 10:22am UTC](https://meta.discourse.org/t/error-after-restarting-the-discourse/64149/6 "2017-06-08T10:22:35Z")

</div>

Tell me, how can I fix this?

---

<div class="post-metadata">

### Author: ![cpradio](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/cpradio/32/4970_2.png) [@cpradio](https://meta.discourse.org/u/cpradio)
#### Post date: [June 8, 2017, 11:29am UTC](https://meta.discourse.org/t/error-after-restarting-the-discourse/64149/7 "2017-06-08T11:29:57Z")

</div>

Well, you can wait 24 hours and try re-enabling the plugin and doing another rebuild, maybe by then rubygems might not be throttling you (though to be honest, I’m not sure I see it as a throttling issue, considering the error happens between two rubygem downloads/installs… that or I’m reading the output wrong).

---

<div class="post-metadata">

### Author: ![robbyoconnor](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/robbyoconnor/32/120330_2.png) [@robbyoconnor](https://meta.discourse.org/u/robbyoconnor)
#### Post date: [June 8, 2017, 8:45pm UTC](https://meta.discourse.org/t/error-after-restarting-the-discourse/64149/8 "2017-06-08T20:45:02Z")

</div>

> [@11145](#):
>
> Tell me, how can I fix this?

The issue is that your ip block is likely hammering the rubygems server…the solution is likely to use something like DigitalOcean, I rarely have this issue. Something is weird but this is not a discourse issue, you should contact rubygems – you can read more about it [here](http://guides.rubygems.org/rubygems-org-api/#rate-limits). I never actually saw this issue. I use Rackspace for the discourse instance I maintain…I’d bet money this is an AWS issue.

---

<div class="post-metadata">

### Author: ![11145](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/11145/32/119636_2.png) [@11145](https://meta.discourse.org/u/11145)
#### Post date: [June 9, 2017, 3:43am UTC](https://meta.discourse.org/t/error-after-restarting-the-discourse/64149/9 "2017-06-09T03:43:09Z")

</div>

Tried to plugin the plugin `discourse-rss-poster` , but the same error  
[https://pastebin.com/H8dSU9CF](https://pastebin.com/H8dSU9CF)

---

<div class="post-metadata">

### Author: ![robbyoconnor](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/robbyoconnor/32/120330_2.png) [@robbyoconnor](https://meta.discourse.org/u/robbyoconnor)
#### Post date: [June 9, 2017, 4:46am UTC](https://meta.discourse.org/t/error-after-restarting-the-discourse/64149/10 "2017-06-09T04:46:38Z")

</div>

> [@11145](#):
>
> Tried to plugin the plugin discourse-rss-poster , but the same error  
> [https://pastebin.com/H8dSU9CF](https://pastebin.com/H8dSU9CF)

You are being throttled due to hitting the rate limit by rubygems. I repeat: this is not a discourse issue.

Look at line 639 onwards in your paste and read it ;).

---

<div class="post-metadata">

### Author: ![robbyoconnor](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/robbyoconnor/32/120330_2.png) [@robbyoconnor](https://meta.discourse.org/u/robbyoconnor)
#### Post date: [June 9, 2017, 4:59am UTC](https://meta.discourse.org/t/error-after-restarting-the-discourse/64149/11 "2017-06-09T04:59:48Z")

</div>

One other thing you could do: install another plugin in place of discourse-rss-poster – does that cause you to hit the rate limit as well? I suspect it will.

---

<div class="post-metadata">

### Author: ![JagWaugh](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/jagwaugh/32/69335_2.png) [@JagWaugh](https://meta.discourse.org/u/JagWaugh)
#### Post date: [June 9, 2017, 5:07am UTC](https://meta.discourse.org/t/error-after-restarting-the-discourse/64149/12 "2017-06-09T05:07:38Z")

</div>

Are you using a plain Ubuntu AMI, or did you take a prebuilt one from the marketplace?

Last week someone was having similar problems with an Intuz pre-built AMI - the issues went away when they moved to a plain Ubuntu 16 AMI and migrated their instance. See here:  
[https://meta.discourse.org/t/upgrade-error-on-aws-free-tier-t2-micro/63756](https://meta.discourse.org/t/upgrade-error-on-aws-free-tier-t2-micro/63756)

---

<div class="post-metadata">

### Author: ![11145](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/11145/32/119636_2.png) [@11145](https://meta.discourse.org/u/11145)
#### Post date: [June 9, 2017, 5:11am UTC](https://meta.discourse.org/t/error-after-restarting-the-discourse/64149/13 "2017-06-09T05:11:38Z")

</div>

> [@Falco](#):
>
> discourse-rss-poster

And why if I disabled the plug-in “discourse-rss-poster” then everything works.  
But is it worth it to include, then download discourse fails?

---

<div class="post-metadata">

### Author: ![11145](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/11145/32/119636_2.png) [@11145](https://meta.discourse.org/u/11145)
#### Post date: [June 11, 2017, 3:11am UTC](https://meta.discourse.org/t/error-after-restarting-the-discourse/64149/15 "2017-06-11T03:11:14Z")

</div>

Updated the discourse to the latest version, when the plug-in is activated, the discourse never starts. Is this problem in the `discourse-rss-poster` plug-in?

---

<div class="post-metadata">

### Author: ![robbyoconnor](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/robbyoconnor/32/120330_2.png) [@robbyoconnor](https://meta.discourse.org/u/robbyoconnor)
#### Post date: [June 11, 2017, 5:34am UTC](https://meta.discourse.org/t/error-after-restarting-the-discourse/64149/16 "2017-06-11T05:34:59Z")

</div>

@11145 – where is this hosted?

---

<div class="post-metadata">

### Author: ![11145](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/11145/32/119636_2.png) [@11145](https://meta.discourse.org/u/11145)
#### Post date: [June 11, 2017, 5:49am UTC](https://meta.discourse.org/t/error-after-restarting-the-discourse/64149/17 "2017-06-11T05:49:38Z")

</div>

Answered in a personal

---

<div class="post-metadata">

### Author: ![JammyDodger](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/jammydodger/32/254611_2.png) [@JammyDodger](https://meta.discourse.org/u/JammyDodger)
#### Post date: [June 8, 2024, 12:44pm UTC](https://meta.discourse.org/t/error-after-restarting-the-discourse/64149/18 "2024-06-08T12:44:43Z")

</div>

This topic was automatically closed after 2557 days. New replies are no longer allowed.
