Error code: 500 when trying to access user admin page of an administrator

Its weird tho, I had access to these pages after the install. It just happend randomly…

Have you tried a restart of the machine?

Is the Linux side all up to date?

We had some date problems when we went live, but our site was an import.

Linux is up-to-date. Rebooting the system rn

Reboot did nothing.

Administrative page of a normal user:57%20AM

Error: yGAGdBt1TaKE_jLtK3dsRg
Look at that URL. Is this normal or does my forum somehow redirect me to a wrong URL and that causes the error?

It should be /admin/users/list/staff

Have you changed any .css etc?
Have you tried /safe-mode

EDIT:

make that /admin/users/1/username

I did not edit any CSS/HTML. Using the standard Light Theme.
Safe mode did nothing, tried that before.

This gives me the staff list. The error happens when you are trying to open the administrative page of a staff user.

(this) (and fyi this is not a admin/mod)

My recommendation is to delete the database and start over. Something like

cd /var/discourse 
rm - r shared/standalone
./launcher rebuild app

If you’ve got plugins installed. Start with all of them commented out.

I just gave up and reinstalled Discourse.

Thanks for the tip tho!

2 Likes