ERROR: column topics.star_count does not exist


(Mirza Memic) #1

Hello,

I am not using docker since latest version it is not supported on 6.4 Centos. I did install manually but I am having trouble to grab latest from master.

After migrate & bundle forum is not working anymore because of missing field (there is a migration which removed this field)

Has anyone run into the same problem?

Here is the detailed log

Processing by ListController#latest as HTML
PG::Error: ERROR:  column topics.star_count does not exist
LINE 1: ..." AS t0_r19, "topics"."bookmark_count" AS t0_r20, "topics"."...
                                                             ^
: SELECT  "topics"."id" AS t0_r0, "topics"."title" AS t0_r1, "topics"."last_posted_at" AS t0_r2, "topics"."created_at" AS t0_r3, "topics"."updated_at" AS t0_r4, "topics"."v$
Completed 500 Internal Server Error in 63ms

ActiveRecord::StatementInvalid (PG::Error: ERROR:  column topics.star_count does not exist
LINE 1: ..." AS t0_r19, "topics"."bookmark_count" AS t0_r20, "topics"."...
                                                             ^
: SELECT  "topics"."id" AS t0_r0, "topics"."title" AS t0_r1, "topics"."last_posted_at" AS t0_r2, "topics"."created_at" AS t0_r3, "topics"."updated_at" AS t0_r4, "topics"."v$
  app/models/topic_list.rb:25:in `topics'
  app/serializers/topic_list_serializer.rb:21:in `include_more_topics_url?'
  app/controllers/list_controller.rb:189:in `block (2 levels) in respond'
  app/controllers/list_controller.rb:186:in `respond'
  app/controllers/list_controller.rb:67:in `block (2 levels) in <class:ListController>'
  lib/middleware/anonymous_cache.rb:117:in `call'
  config/initializers/quiet_logger.rb:10:in `call_with_quiet_assets'
  config/initializers/silence_logger.rb:26:in `call'

#2

Since non-docker installs aren’t supported, the official devs have no obligation to help (and they usually don’t). But if another independent non-docker user had this problem, they might be able to help if they are willing.


(Mirza Memic) #3

I knew that. Wanted to try anyway.


(Jens Maier) #4

Looks like a version mismatch. The currently running code still has support for starred topics, but that feature was recently removed and the corresponding database column was removed by a Rails migration.

Did you restart your Discourse instance after updating to latest tests-passed, bundle install, rake db:migrate, rake assets:precompile?


(Mirza Memic) #5

Thanks for the help. Yes I did - tried both stable and master branches. Still gives the same error.


(Jens Maier) #6

Yes but did you actually shut down and restart the Discourse app? It looks like the code that’s running isn’t the code that’s currently in the master (or tests-passed) branch.


(RĂ©gis Hanol) #7

Seems like you haven’t migrated to the latest db version. Try running bundle exec rake db:migrate.


(Mirza Memic) #8

restarted nginx and redis. bluepill stopped and started again. I have all the migrations.

bundle exec rake db:migrate RAILS_ENV=production
bundle exec assets:precompile RAILS_ENV=production

Just tried to setup docker one more time. Not an option for me.

You are running linux kernel version 2.6.32-431.23.3.el6.x86_64, which might be unstable running docker. Please upgrade your kernel to 3.8.0.


(Jens Maier) #9

Ugh, bluepill… Does stopping bluepill even stop the thin workers? Because those are what you need to restart in order to get Discouse to use the new ruby code.

Of course, you could simply reboot…


(Sam Saffron) #10

BLUEPILLLL


(Julien Grillot) #11

Same problem when I switched from 1.1.3 to 1.2.1. Upgrading to 1.3.0.beta3 fixed everything.


(Jeff Atwood) #12