# Error connecting to Redis

**URL:** https://meta.discourse.org/t/error-connecting-to-redis/135678
**Category:** Self-hosting
**Created:** [December 11, 2019, 6:00pm UTC](https://meta.discourse.org/t/error-connecting-to-redis/135678 "2019-12-11T18:00:05Z")
**Posts on this page:** 18
**Page:** 1

<div class="post-metadata">

### Author: ![CRUGG](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/crugg/32/161184_2.png) [@CRUGG](https://meta.discourse.org/u/CRUGG)
#### Post date: [December 11, 2019, 6:00pm UTC](https://meta.discourse.org/t/error-connecting-to-redis/135678/1 "2019-12-11T18:00:05Z")

</div>

When I try to start discourse, I can’t access it in my browser. I found some information in the log files which might cause this. Does somebody know what the problem is?

```plaintext
# /var/discourse/standalone/log/rails/unicorn.stderr.log
Failed to report error: Error connecting to Redis on localhost:6379 (Errno::EADDRNOTAVAIL) 2 Error connecting to Redis on localhost:6379 (Errno::EADDRNOTAVAIL) subscribe failed, reconnecting in 1 second. Call stack ["/var/www/discourse/vendor/bundle/ruby/2.6.0/gems/redis-4.1.3/lib/redis/client.rb:362:in `rescue in establish_connection'", "/var/www/discourse/vendor/bundle/ruby/2.6.0/gems/redis-4.1.3/lib/redis/client.rb:343:in `establish_connection'", "/var/www/discourse/vendor/bundle/ruby/2.6.0/gems/redis-4.1.3/lib/redis/client.rb:106:in `block in connect'", "/var/www/discourse/vendor/bundle/ruby/2.6.0/gems/redis-4.1.3/lib/redis/client.rb:306:in `with_reconnect'", "/var/www/discourse/vendor/bundle/ruby/2.6.0/gems/redis-4.1.3/lib/redis/client.rb:105:in `connect'", "/var/www/discourse/vendor/bundle/ruby/2.6.0/gems/redis-4.1.3/lib/redis/client.rb:381:in `ensure_connected'", "/var/www/discourse/vendor/bundle/ruby/2.6.0/gems/redis-4.1.3/lib/redis/client.rb:231:in `block in process'", "/var/www/discourse/vendor/bundle/ruby/2.6.0/gems/redis-4.1.3/lib/redis/client.rb:319:in `logging'", "/var/www/discourse/vendor/bundle/ruby/2.6.0/gems/redis-4.1.3/lib/redis/client.rb:230:in `process'", "/var/www/discourse/vendor/bundle/ruby/2.6.0/gems/redis-4.1.3/lib/redis/client.rb:139:in `block in call_loop'", "/var/www/discourse/vendor/bundle/ruby/2.6.0/gems/redis-4.1.3/lib/redis/client.rb:292:in `with_socket_timeout'", "/var/www/discourse/vendor/bundle/ruby/2.6.0/gems/redis-4.1.3/lib/redis/client.rb:138:in `call_loop'", "/var/www/discourse/vendor/bundle/ruby/2.6.0/gems/redis-4.1.3/lib/redis/subscribe.rb:43:in `subscription'", "/var/www/discourse/vendor/bundle/ruby/2.6.0/gems/redis-4.1.3/lib/redis/subscribe.rb:12:in `subscribe'", "/var/www/discourse/vendor/bundle/ruby/2.6.0/gems/redis-4.1.3/lib/redis.rb:3467:in `_subscription'", "/var/www/discourse/vendor/bundle/ruby/2.6.0/gems/redis-4.1.3/lib/redis.rb:2300:in `block in subscribe'", "/var/www/discourse/vendor/bundle/ruby/2.6.0/gems/redis-4.1.3/lib/redis.rb:52:in `block in synchronize'", "/usr/local/lib/ruby/2.6.0/monitor.rb:235:in `mon_synchronize'", "/var/www/discourse/vendor/bundle/ruby/2.6.0/gems/redis-4.1.3/lib/redis.rb:52:in `synchronize'", "/var/www/discourse/vendor/bundle/ruby/2.6.0/gems/redis-4.1.3/lib/redis.rb:2299:in `subscribe'", "/var/www/discourse/vendor/bundle/ruby/2.6.0/gems/message_bus-2.2.3/lib/message_bus/backends/redis.rb:287:in `global_subscribe'", "/var/www/discourse/vendor/bundle/ruby/2.6.0/gems/message_bus-2.2.3/lib/message_bus.rb:721:in `global_subscribe_thread'", "/var/www/discourse/vendor/bundle/ruby/2.6.0/gems/message_bus-2.2.3/lib/message_bus.rb:669:in `block in new_subscriber_thread'"]
Failed to report error: Error connecting to Redis on localhost:6379 (Errno::EADDRNOTAVAIL) 3 Job exception: Error connecting to Redis on localhost:6379 (Errno::EADDRNOTAVAIL)

```

```plaintext
# /shared/standalone/log/var-log/redis/current
40:M 11 Dec 2019 17:46:24.868 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
40:M 11 Dec 2019 17:46:24.868 # Server initialized
40:M 11 Dec 2019 17:46:24.868 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add 'vm.overcommit_memory = 1' to /etc/sysctl.conf and then reboot or run the command 'sysctl vm.overcommit_memory=1' for this to take effect.
40:M 11 Dec 2019 17:46:24.868 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command 'echo never > /sys/kernel/mm/transparent_hugepage/enabled' as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
40:M 11 Dec 2019 17:46:24.885 * DB loaded from disk: 0.017 seconds
40:M 11 Dec 2019 17:46:24.891 * Ready to accept connections

```

If those very long log lines are too hard to read on here, I’ve also put them up on hasteb.in: [https://hasteb.in/cipemeki.rb](https://hasteb.in/cipemeki.rb)

---

<div class="post-metadata">

### Author: ![sam](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/sam/32/102149_2.png) [@sam](https://meta.discourse.org/u/sam)
#### Post date: [December 11, 2019, 11:35pm UTC](https://meta.discourse.org/t/error-connecting-to-redis/135678/2 "2019-12-11T23:35:15Z")

</div>

Something strange is going on here. I recommend upgrading docker, rebooting your server and rebuilding discourse.

---

<div class="post-metadata">

### Author: ![CRUGG](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/crugg/32/161184_2.png) [@CRUGG](https://meta.discourse.org/u/CRUGG)
#### Post date: [December 12, 2019, 12:06pm UTC](https://meta.discourse.org/t/error-connecting-to-redis/135678/3 "2019-12-12T12:06:44Z")

</div>

Sucessfully upgraded Docker using `apt upgrade docker` (it wasn’t the newest version), rebooted Server via `reboot`, rebuilt using `./launcher rebuild app` (got some redis warnings while rebuildings, but they are mostly the same as in the var-log/redis/current file), but I still can’t access my site. I tried accessing accessing it via apache2 as a Proxy (ProxyPass) which gives me a 503 Error and through the ip and the http port (I’ve disabled HTTPS) which just gives me an “ERR\_CONNECTION\_REFUSED” error from my browser.  
This time the unicorn.stderr.log just outputs the following:

```plaintext
I, [2019-12-12T11:58:37.378657 #70] INFO -- : Refreshing Gem list
I, [2019-12-12T11:58:56.751681 #70] INFO -- : listening on addr=127.0.0.1:3000 fd=9
I, [2019-12-12T11:59:04.682642 #70] INFO -- : master process ready
I, [2019-12-12T11:59:23.890076 #172] INFO -- : worker=0 ready
I, [2019-12-12T11:59:24.852000 #179] INFO -- : worker=1 ready

```

and the redis current file still outputs the warnings like before.

---

<div class="post-metadata">

### Author: ![CRUGG](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/crugg/32/161184_2.png) [@CRUGG](https://meta.discourse.org/u/CRUGG)
#### Post date: [December 23, 2019, 3:26pm UTC](https://meta.discourse.org/t/error-connecting-to-redis/135678/4 "2019-12-23T15:26:54Z")

</div>

Does nobody have a solution for this? I still haven’t found a way to fix this.

---

<div class="post-metadata">

### Author: ![pfaffman](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/pfaffman/32/120154_2.png) [@pfaffman](https://meta.discourse.org/u/pfaffman)
#### Post date: [December 23, 2019, 3:54pm UTC](https://meta.discourse.org/t/error-connecting-to-redis/135678/5 "2019-12-23T15:54:35Z")

</div>

It’s nothing obvious. What about `/var/discourse/shared/standalone/logs/rails/production.log` (if I can type)?

---

<div class="post-metadata">

### Author: ![CRUGG](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/crugg/32/161184_2.png) [@CRUGG](https://meta.discourse.org/u/CRUGG)
#### Post date: [December 23, 2019, 3:56pm UTC](https://meta.discourse.org/t/error-connecting-to-redis/135678/6 "2019-12-23T15:56:18Z")

</div>

There is no `logs` Folder inside of `shared`.

---

<div class="post-metadata">

### Author: ![Falco](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/falco/32/179432_2.png) [@Falco](https://meta.discourse.org/u/Falco)
#### Post date: [December 23, 2019, 4:26pm UTC](https://meta.discourse.org/t/error-connecting-to-redis/135678/7 "2019-12-23T16:26:26Z")

</div>

It’s `log` instead of `logs`. You gonna have to help us to help you…

---

<div class="post-metadata">

### Author: ![CRUGG](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/crugg/32/161184_2.png) [@CRUGG](https://meta.discourse.org/u/CRUGG)
#### Post date: [December 24, 2019, 9:04am UTC](https://meta.discourse.org/t/error-connecting-to-redis/135678/8 "2019-12-24T09:04:20Z")

</div>

The production.log File is just empty.

---

<div class="post-metadata">

### Author: ![CRUGG](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/crugg/32/161184_2.png) [@CRUGG](https://meta.discourse.org/u/CRUGG)
#### Post date: [January 7, 2020, 7:05pm UTC](https://meta.discourse.org/t/error-connecting-to-redis/135678/9 "2020-01-07T19:05:05Z")

</div>

And I still haven’t found a way to fix this yet. I’ve also been talking to some Forum Admins using Discourse and nobody I found seems to have had this issue.

---

<div class="post-metadata">

### Author: ![bobhy](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/bobhy/32/167661_2.png) [@bobhy](https://meta.discourse.org/u/bobhy)
#### Post date: [January 26, 2020, 2:13am UTC](https://meta.discourse.org/t/error-connecting-to-redis/135678/10 "2020-01-26T02:13:15Z")

</div>

I am also having this issue.  
In: unicorn.stdout.log:

```
Starting up 1 supervised sidekiqs
Loading Sidekiq in process id 4160
2020-01-25T19:29:16.281Z pid=4160 tid=orb7qpo9c ERROR: Error fetching job: Error connecting to Redis on localhost:6379 (Errno::EADDRNOTAVAIL)
2020-01-25T19:29:16.288Z pid=4160 tid=orb7qpoj0 ERROR: Error fetching job: Error connecting to Redis on localhost:6379 (Errno::EADDRNOTAVAIL)
2020-01-25T19:29:16.287Z pid=4160 tid=orb7rr8k4 ERROR: Error fetching job: Error connecting to Redis on localhost:6379 (Errno::EADDRNOTAVAIL)
2020-01-25T19:29:16.283Z pid=4160 tid=orb7qpop4 ERROR: Error fetching job: Error connecting to Redis on localhost:6379 (Errno::EADDRNOTAVAIL)

```

This is brand new Discourse install, standalone container with unix socket connection to outer nginx. I’m trying to embed Discourse in Ghost site for comments, the errors are correlated with displaying a post with a Discourse embed (and Discourse tries to queue a job to parse the referring page?) I had a similar config working for a year but that one blew up trying to upgrade, so I’m reconfiguring from (faulty) memory. Plenty of room for user error here …

Unicorn logs show redis connect error  
[production.log.txt](https://meta.discourse.org/uploads/short-url/o5JSTIa7q2wolsmFuN0Q7syWrLR.txt) (155.8 KB) [unicorn.stderr.log.txt](https://meta.discourse.org/uploads/short-url/wWDvymDLIKfVDs8zKBZpViGj5rk.txt) (14.5 KB)

redis itself seems happy (from `standalone/log/var-log/redis/current`) [current.txt](https://meta.discourse.org/uploads/short-url/tYA0ZeGdYDZkqMkxu0JHpUCnaEY.txt) (37.0 KB)  
and seems to be handling some connections on the expected port :6379. And some of the connections are from unicorn-worker, FWIW.

```plaintext
root@server3:/var/discourse/shared/standalone/log/var-log/redis# nsenter -t $(docker inspect -f '{{.State.Pid}}' app) -n netstat -ap
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name    
tcp 0 0 0.0.0.0:6379 0.0.0.0:* LISTEN 2250/redis-server * 
tcp 0 0 localhost.localdom:3000 0.0.0.0:* LISTEN 2280/unicorn master 
tcp 0 0 0.0.0.0:postgresql 0.0.0.0:* LISTEN 2253/postmaster     
tcp 0 0 localhost.localdo:45404 localhost.localdom:6379 ESTABLISHED 3004/unicorn worker 
tcp 0 0 localhost.localdo:45448 localhost.localdom:6379 ESTABLISHED 2981/unicorn worker 
tcp 0 0 localhost.localdom:6379 localhost.localdo:45408 ESTABLISHED 2250/redis-server * 
tcp 0 0 localhost.localdo:45346 localhost.localdom:6379 ESTABLISHED 2280/unicorn master 
tcp 0 0 localhost.localdo:45456 localhost.localdom:6379 ESTABLISHED 3013/unicorn worker 
tcp 0 0 localhost.localdom:3000 localhost.localdo:49628 TIME_WAIT -                   
tcp 0 0 localhost.localdo:45426 localhost.localdom:6379 ESTABLISHED 3022/unicorn worker 
tcp 0 0 localhost.localdom:6379 localhost.localdo:45346 ESTABLISHED 2250/redis-server * 
tcp 0 0 localhost.localdo:45336 localhost.localdom:6379 ESTABLISHED 2280/unicorn master 
tcp 0 0 localhost.localdom:6379 localhost.localdo:45392 ESTABLISHED 2250/redis-server * 
tcp 0 0 localhost.localdo:45458 localhost.localdom:6379 ESTABLISHED 3022/unicorn worker 
tcp 0 0 localhost.localdo:45452 localhost.localdom:6379 ESTABLISHED 3004/unicorn worker 
tcp 0 0 localhost.localdo:45380 localhost.localdom:6379 ESTABLISHED 2981/unicorn worker 
tcp 0 0 localhost.localdom:6379 localhost.localdo:45410 ESTABLISHED 2250/redis-server * 
tcp 0 0 localhost.localdo:45390 localhost.localdom:6379 ESTABLISHED 2970/sidekiq 6.0.4  
tcp 0 0 localhost.localdo:45374 localhost.localdom:6379 ESTABLISHED 2970/sidekiq 6.0.4  
tcp 0 0 localhost.localdo:45420 localhost.localdom:6379 ESTABLISHED 3013/unicorn worker 
tcp 0 0 localhost.localdom:6379 localhost.localdo:45400 ESTABLISHED 2250/redis-server * 
tcp 0 0 localhost.localdom:6379 localhost.localdo:45390 ESTABLISHED 2250/redis-server * 
tcp 0 0 localhost.localdo:45332 localhost.localdom:6379 ESTABLISHED 2280/unicorn master 
tcp 0 0 localhost.localdo:45392 localhost.localdom:6379 ESTABLISHED 2970/sidekiq 6.0.4  
tcp 0 0 localhost.localdom:3000 localhost.localdo:49626 TIME_WAIT -                   
tcp 0 0 localhost.localdom:6379 localhost.localdo:45386 ESTABLISHED 2250/redis-server * 
tcp 0 0 localhost.localdom:6379 localhost.localdo:45428 ESTABLISHED 2250/redis-server * 
tcp 0 0 localhost.localdom:6379 localhost.localdo:45414 ESTABLISHED 2250/redis-server * 
tcp 0 0 localhost.localdom:6379 localhost.localdo:45368 ESTABLISHED 2250/redis-server * 
tcp 0 0 localhost.localdom:6379 localhost.localdo:45332 ESTABLISHED 2250/redis-server * 
tcp 0 0 localhost.localdo:45376 localhost.localdom:6379 ESTABLISHED 2970/sidekiq 6.0.4  
tcp 0 0 localhost.localdo:45396 localhost.localdom:6379 ESTABLISHED 2970/sidekiq 6.0.4  
tcp 0 0 localhost.localdom:6379 localhost.localdo:45418 ESTABLISHED 2250/redis-server * 
tcp 0 0 localhost.localdom:6379 localhost.localdo:45448 ESTABLISHED 2250/redis-server * 
tcp 0 0 localhost.localdom:6379 localhost.localdo:45388 ESTABLISHED 2250/redis-server * 
tcp 0 0 localhost.localdom:6379 localhost.localdo:45374 ESTABLISHED 2250/redis-server * 
tcp 0 0 localhost.localdo:45408 localhost.localdom:6379 ESTABLISHED 3004/unicorn worker 
tcp 0 0 localhost.localdo:45386 localhost.localdom:6379 ESTABLISHED 2981/unicorn worker 
tcp 0 0 localhost.localdom:6379 localhost.localdo:45398 ESTABLISHED 2250/redis-server * 
tcp 0 0 localhost.localdo:45398 localhost.localdom:6379 ESTABLISHED 2970/sidekiq 6.0.4  
tcp 0 0 localhost.localdom:6379 localhost.localdo:45430 ESTABLISHED 2250/redis-server * 
tcp 0 0 localhost.localdom:6379 localhost.localdo:45394 ESTABLISHED 2250/redis-server * 
tcp 0 0 localhost.localdom:6379 localhost.localdo:45458 ESTABLISHED 2250/redis-server * 
tcp 0 0 localhost.localdom:6379 localhost.localdo:45456 ESTABLISHED 2250/redis-server * 
tcp 0 0 localhost.localdom:6379 localhost.localdo:45420 ESTABLISHED 2250/redis-server * 
tcp 0 0 localhost.localdom:6379 localhost.localdo:45396 ESTABLISHED 2250/redis-server * 
tcp 0 0 localhost.localdo:45394 localhost.localdom:6379 ESTABLISHED 2970/sidekiq 6.0.4  
tcp 0 0 localhost.localdo:45368 localhost.localdom:6379 ESTABLISHED 2970/sidekiq 6.0.4  
tcp 0 0 localhost.localdom:6379 localhost.localdo:45426 ESTABLISHED 2250/redis-server * 
tcp 0 0 localhost.localdom:6379 localhost.localdo:45376 ESTABLISHED 2250/redis-server * 
tcp 0 0 localhost.localdo:45428 localhost.localdom:6379 ESTABLISHED 3022/unicorn worker 
tcp 0 0 localhost.localdom:6379 localhost.localdo:45404 ESTABLISHED 2250/redis-server * 
tcp 0 0 localhost.localdo:45400 localhost.localdom:6379 ESTABLISHED 2970/sidekiq 6.0.4  
tcp 0 0 localhost.localdo:45388 localhost.localdom:6379 ESTABLISHED 2970/sidekiq 6.0.4  
tcp 0 0 localhost.localdo:45414 localhost.localdom:6379 ESTABLISHED 3013/unicorn worker 
tcp 0 0 localhost.localdom:6379 localhost.localdo:45336 ESTABLISHED 2250/redis-server * 
tcp 0 0 localhost.localdo:45418 localhost.localdom:6379 ESTABLISHED 3013/unicorn worker 
tcp 0 0 localhost.localdo:45384 localhost.localdom:6379 ESTABLISHED 2981/unicorn worker 
tcp 0 0 localhost.localdom:6379 localhost.localdo:45384 ESTABLISHED 2250/redis-server * 
tcp 0 0 localhost.localdo:45430 localhost.localdom:6379 ESTABLISHED 3022/unicorn worker 
tcp 0 0 localhost.localdo:45410 localhost.localdom:6379 ESTABLISHED 3004/unicorn worker 
tcp 0 0 localhost.localdom:6379 localhost.localdo:45380 ESTABLISHED 2250/redis-server * 
tcp 0 0 localhost.localdom:6379 localhost.localdo:45452 ESTABLISHED 2250/redis-server * 
tcp6 0 0 [::]:6379 [::]:* LISTEN 2250/redis-server * 
tcp6 0 0 [::]:postgresql [::]:* LISTEN 2253/postmaster     
udp 0 0 localhost.localdo:57631 localhost.localdo:57631 ESTABLISHED 2253/postmaster     
Active UNIX domain sockets (servers and established)
Proto RefCnt Flags Type State I-Node PID/Program name Path
unix 2 [ACC] STREAM LISTENING 10681809 2253/postmaster /var/run/postgresql/.s.PGSQL.5432
unix 3 [] DGRAM 10681045 2247/rsyslogd /dev/log
unix 2 [ACC] STREAM LISTENING 10682768 2257/nginx: master /shared/nginx.http.sock
unix 3 [] STREAM CONNECTED 10682773 2257/nginx: master   
unix 3 [] STREAM CONNECTED 10682778 2257/nginx: master   
unix 3 [] STREAM CONNECTED 10682772 2257/nginx: master   
unix 3 [] STREAM CONNECTED 10682776 2257/nginx: master   
unix 3 [] STREAM CONNECTED 10682770 2257/nginx: master   
unix 3 [] STREAM CONNECTED 10682774 2257/nginx: master   
unix 3 [] STREAM CONNECTED 10682775 2257/nginx: master   
unix 2 [] DGRAM 10681046 2247/rsyslogd        
unix 3 [] STREAM CONNECTED 10682777 2257/nginx: master   
unix 3 [] STREAM CONNECTED 10682779 2257/nginx: master   
unix 3 [] STREAM CONNECTED 10682771 2257/nginx: master   
unix 3 [] STREAM CONNECTED 10766487 2970/sidekiq 6.0.4   
unix 3 [] STREAM CONNECTED 10683830 2280/unicorn master  
unix 3 [] STREAM CONNECTED 10764869 27949/postgres: 10/ /var/run/postgresql/.s.PGSQL.5432
unix 3 [] STREAM CONNECTED 10684631 2750/postgres: 10/m /var/run/postgresql/.s.PGSQL.5432
root@server3:/var/discourse/shared/standalone/log/var-log/redis# 

```

---

<div class="post-metadata">

### Author: ![stretch](https://avatars.discourse-cdn.com/v4/letter/s/a6a055/32.png) [@stretch](https://meta.discourse.org/u/stretch)
#### Post date: [February 6, 2020, 12:52am UTC](https://meta.discourse.org/t/error-connecting-to-redis/135678/11 "2020-02-06T00:52:33Z")

</div>

I have the same problem.  
I have the error EADDRNOTAVAIL on localhost:6379 multiple times in my log files. I will post them if asked.

---

<div class="post-metadata">

### Author: ![pfaffman](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/pfaffman/32/120154_2.png) [@pfaffman](https://meta.discourse.org/u/pfaffman)
#### Post date: [February 6, 2020, 12:55am UTC](https://meta.discourse.org/t/error-connecting-to-redis/135678/12 "2020-02-06T00:55:20Z")

</div>

Are those connection problems intermittent or are they all just when the container is starting up and redis starts after unicorn?

---

<div class="post-metadata">

### Author: ![stretch](https://avatars.discourse-cdn.com/v4/letter/s/a6a055/32.png) [@stretch](https://meta.discourse.org/u/stretch)
#### Post date: [February 6, 2020, 3:28pm UTC](https://meta.discourse.org/t/error-connecting-to-redis/135678/13 "2020-02-06T15:28:30Z")

</div>

The error is scattered around the log file, but only appears once when rebuilding.

---

<div class="post-metadata">

### Author: ![KevinBlandy](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/kevinblandy/32/155478_2.png) [@KevinBlandy](https://meta.discourse.org/u/KevinBlandy)
#### Post date: [February 13, 2020, 1:24pm UTC](https://meta.discourse.org/t/error-connecting-to-redis/135678/14 "2020-02-13T13:24:15Z")

</div>

I have the same problem！！ 😭

---

<div class="post-metadata">

### Author: ![Rene\_Bormann](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/rene_bormann/32/81648_2.png) [@Rene\_Bormann](https://meta.discourse.org/u/Rene_Bormann)
#### Post date: [March 12, 2020, 5:15pm UTC](https://meta.discourse.org/t/error-connecting-to-redis/135678/15 "2020-03-12T17:15:47Z")

</div>

Hi guys,

I just updated via ssh.  
went to /var/discourse and ./launcher rebuild app.

and now no pages are delivered.  
seems not to connect to redis.

any ideas?

Thanks from Hamburg,  
René

---

<div class="post-metadata">

### Author: ![pfaffman](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/pfaffman/32/120154_2.png) [@pfaffman](https://meta.discourse.org/u/pfaffman)
#### Post date: [March 12, 2020, 9:57pm UTC](https://meta.discourse.org/t/error-connecting-to-redis/135678/16 "2020-03-12T21:57:51Z")

</div>

Check disk space? What is your evidence that you’re not connecting to redis?

---

<div class="post-metadata">

### Author: ![tao\_oat](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/tao_oat/32/180718_2.png) [@tao\_oat](https://meta.discourse.org/u/tao_oat)
#### Post date: [May 17, 2020, 1:42pm UTC](https://meta.discourse.org/t/error-connecting-to-redis/135678/17 "2020-05-17T13:42:44Z")

</div>

I’m running into the same error on an new Docker installation of Discourse. It worked fine, then I took it down to set up for Postgres 12 and to enable a static maintenance error page. Now, I can’t get Discourse to run again.

There seems to be an issue with Rails connecting to Redis. From `production.log`:

```plaintext
Error connecting to Redis on localhost:6379 (Errno::EADDRNOTAVAIL) subscribe failed, reconnecting in 1 second. Call stack ["/var/www/discourse/vendor/bundle/ruby/2.6.0/gems/redis-4.1.4/lib/redis/client.rb:363:in `rescue in establish_connection'", "/var/www/discourse/vendor/bundle/ruby/2.6.0/gems/redis-4.1.4/lib/redis/client.rb:344:in `establish_connection'", "/var/www/discourse/vendor/bundle/ruby/2.6.0/gems/redis-4.1.4/lib/redis/client.rb:106:in `block in connect'", "/var/www/discourse/vendor/bundle/ruby/2.6.0/gems/redis-4.1.4/lib/redis/client.rb:307:in `with_reconnect'", "/var/www/discourse/vendor/bundle/ruby/2.6.0/gems/redis-4.1.4/lib/redis/client.rb:105:in `connect'", "/var/www/discourse/vendor/bundle/ruby/2.6.0/gems/redis-4.1.4/lib/redis/client.rb:382:in `ensure_connected'", "/var/www/discourse/vendor/bundle/ruby/2.6.0/gems/redis-4.1.4/lib/redis/client.rb:231:in `block in process'", "/var/www/discourse/vendor/bundle/ruby/2.6.0/gems/redis-4.1.4/lib/redis/client.rb:320:in `logging'", "/var/www/discourse/vendor/bundle/ruby/2.6.0/gems/redis-4.1.4/lib/redis/client.rb:230:in `process'", "/var/www/discourse/vendor/bundle/ruby/2.6.0/gems/redis-4.1.4/lib/redis/client.rb:125:in `call'", "/var/www/discourse/vendor/bundle/ruby/2.6.0/gems/redis-4.1.4/lib/redis.rb:915:in `block in get'", "/var/www/discourse/vendor/bundle/ruby/2.6.0/gems/redis-4.1.4/lib/redis.rb:51:in `block in synchronize'", "/usr/local/lib/ruby/2.6.0/monitor.rb:235:in `mon_synchronize'", "/var/www/discourse/vendor/bundle/ruby/2.6.0/gems/redis-4.1.4/lib/redis.rb:51:in `synchronize'", "/var/www/discourse/vendor/bundle/ruby/2.6.0/gems/redis-4.1.4/lib/redis.rb:914:in `get'", "/var/www/discourse/vendor/bundle/ruby/2.6.0/gems/message_bus-3.2.0/lib/message_bus/backends/redis.rb:360:in `process_global_backlog'", "/var/www/discourse/vendor/bundle/ruby/2.6.0/gems/message_bus-3.2.0/lib/message_bus/backends/redis.rb:271:in `block in global_subscribe'", "/var/www/discourse/vendor/bundle/ruby/2.6.0/gems/message_bus-3.2.0/lib/message_bus/backends/redis.rb:284:in `global_subscribe'", "/var/www/discourse/vendor/bundle/ruby/2.6.0/gems/message_bus-3.2.0/lib/message_bus.rb:741:in `global_subscribe_thread'", "/var/www/discourse/vendor/bundle/ruby/2.6.0/gems/message_bus-3.2.0/lib/message_bus.rb:689:in `block in new_subscriber_thread'"]
Creating scope :open. Overwriting existing method Poll.open.
Creating scope :open. Overwriting existing method Poll.open.
Creating scope :open. Overwriting existing method Poll.open.

```

`production_errors.log` is empty. Redis seems to start up normally. It’s worth noticing that the syslog contains these lines:

```plaintext
May 17 13:35:30 wobbly-wiki-forum-app rsyslogd: imklog: cannot open kernel log (/proc/kmsg): Operation not permitted.
May 17 13:35:30 wobbly-wiki-forum-app rsyslogd: activation of module imklog failed [v8.1901.0 try https://www.rsyslog.com/e/2145]
May 17 13:35:30 wobbly-wiki-forum-app rsyslogd: [origin software="rsyslogd" swVersion="8.1901.0" x-pid="51" x-info="https://www.rsyslog.com"] start

```

I wonder if they could indicate an issue? FWIW there’s ample available memory and disk space on the server.

EDIT: Now resolved! I was running through an nginx reverse proxy, but had not followed [the instructions](https://meta.discourse.org/t/running-other-websites-on-the-same-machine-as-discourse/17247/1) to the letter. I had forgotten to add the template `"templates/web.socketed.template.yml"`, and I also commented out the entire `expose:` section of `app.yml`. Now it works.

---

<div class="post-metadata">

### Author: ![Danran](https://avatars.discourse-cdn.com/v4/letter/d/ea5d25/32.png) [@Danran](https://meta.discourse.org/u/Danran)
#### Post date: [March 21, 2023, 7:04pm UTC](https://meta.discourse.org/t/error-connecting-to-redis/135678/18 "2023-03-21T19:04:22Z")

</div>

> [@pfaffman](#):
>
> /var/discourse/shared/standalone/logs/rails/production.log

Has anyone else figured out a solution to this? I am encountering this error on a vanilla docker based installation on Ubuntu Server 20.04. I am not running anything though an Nginx reverse proxy. I just used the default docker install script.
