ERROR: Docker version 1.9.1 not supported, please upgrade to at least 17.03.1, or recommended 17.06.2


(Daniel Hollands) #1

I’m trying to run ./launcher rebuild app on my app, but everytime I do, I get this error:

ERROR: Docker version 1.9.1 not supported, please upgrade to at least 17.03.1, or recommended 17.06.2

Can someone point me in the right direction for updating docker please?

I’ve tried sudo apt-get update and sudo apt-get upgrade.

Thank you.


(Jay Pfaffman) #2

If yo search for “docker version not supported” you’ll find Docker version not supported after the later update.


(Andreas Dorfer) #3

From experience: Even if you master the docker-upgrade, you may then strand in some discourse-db-update issues, leaving you with a broken system.

My recommended solution would be: Take a backup (before anything else, make a download…). Attempt docker upgrade, and if this fails, make a fresh install, reinstall from backup.

In plus check for images “missing” (rsync between old and and installation in terms of uploades images.)


(Daniel Hollands) #4

My apologies, I did do a search, but that particular answer evaded me.


(Daniel Hollands) #5

I’ve followed the instructions in that other post, and have gotten the following:

# Executing docker install script, commit: 11aa13e
Warning: the "docker" command appears to already exist on this system.

If you already have Docker installed, this script can cause trouble, which is
why we're displaying this warning and provide the opportunity to cancel the
installation.

If you installed the current Docker package using this script and are using it
again to update Docker, we urge you to migrate your image store before upgrading
to v1.10+.

You can find instructions for this here:
https://github.com/docker/docker/wiki/Engine-v1.10.0-content-addressability-migration

You may press Ctrl+C now to abort this script.

I have taken a backup of the app as it stands right now, so I could just go ahead and try it any way - but I’m not sure I trust it’ll work, and don’t want to have to re-provision the server right now. I fear I may be stuck on the current version of discourse for a while.


(Jay Pfaffman) #6

Sorry. That’s not the message that I remember seeing, but you’re going to build a new image anyway, so you should be safe.

If you have a current backup, worst case you can wipe the system, do a clean install, and restore the backup.