Error in CSS - theme_variables.scss


(Emmanuel Straschnov) #1

Since our last upgrade (yesterday), we see this at the bottom of the page.

Syntax error: Invalid CSS after "...er_background: ": expected expression (e.g. 1px, bold), was "#nil !default;"\A on line 5 of theme_variables.scss\A from line 1 of custom stylesheet

We haven’t changed our CSS, so not sure it’s on our end. Where can I see this file and see what is happening?


(Sam Saffron) #2

hmmm … I don’t know what that file is, my guess is that one of your plugins is bust.

Try safe mode:


(cpradio) #3

I’m not sure it is. I had it happen to me recently too. I ended up resolving it by getting to Admin > Customize > and reverting changes I had to my theme. Then the error went away once I was back on the regular settings.


(Emmanuel Straschnov) #4

I see this the message in safe mode, the raw HTML/CSS being

footer:after {
    content: 'Syntax error: Invalid CSS after "...er_background: ": expected expression (e.g. 1px, bold), was "#nil !default;"\A on line 5 of theme_variables.scss\A from line 32 of /var/www/discourse/app/assets/stylesheets/common/foundation/variables.scss\A from line 1 of /var/www/discourse/app/assets/stylesheets/vendor/pikaday.scss\A from line 3 of /var/www/discourse/app/assets/stylesheets/common.scss\A from line 1 of desktop stylesheet';
}

I can see this in the CSS file under /stylesheets


(Sam Saffron) #5

You are going to have to bring in the big guns,

comment out all the plugins you have from your app.yml and run

./launcher rebuild app

CSS updates stopped working