# Error in install AWS lightsail with CloudFlare

**URL:** https://meta.discourse.org/t/error-in-install-aws-lightsail-with-cloudflare/299168
**Category:** Self-hosting
**Created:** [March 13, 2024, 2:28pm UTC](https://meta.discourse.org/t/error-in-install-aws-lightsail-with-cloudflare/299168 "2024-03-13T14:28:20Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![Ppantaleo](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/ppantaleo/32/370444_2.png) [@Ppantaleo](https://meta.discourse.org/u/Ppantaleo)
#### Post date: [March 13, 2024, 2:28pm UTC](https://meta.discourse.org/t/error-in-install-aws-lightsail-with-cloudflare/299168/1 "2024-03-13T14:28:21Z")

</div>

Hi, I have my domain on namecheap pointing to CloudFlare. In CloudFlare I have an A record pointing to the static ip of my instance in AWS LightSail. But when I run: ./discourse-setup

I get the error:

Checking your domain name . . .  
WARNING: Port 443 of computer does not appear to be accessible using hostname: forum.lata  
[rxiv.org](http://rxiv.org).

SUCCESS: A connection to port 80 succeeds!  
This suggests that your DNS settings are correct,  
but something is keeping traffic to port 443 from getting to your server.  
Check your networking configuration to see that connections to port 443 are allowed.

The first thing to do is confirm that [forum.latarxiv.org](http://forum.latarxiv.org) resolves to the IP address of thi  
s server.  
You usually do this at the same place you purchased the domain.

If you are sure that the IP address resolves correctly, it could be a firewall issue.  
A web search for “open ports YOUR CLOUD SERVICE” might help.

This tool is designed only for the most standard installations. If you cannot resolve  
the issue above, you will need to edit containers/app.yml yourself and then type

./launcher rebuild app

In the web the error is 522

---

<div class="post-metadata">

### Author: ![Lilly](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/lilly/32/575047_2.png) [@Lilly](https://meta.discourse.org/u/Lilly)
#### Post date: [March 13, 2024, 3:43pm UTC](https://meta.discourse.org/t/error-in-install-aws-lightsail-with-cloudflare/299168/2 "2024-03-13T15:43:20Z")

</div>

Hi @Ppantaleo welcome to Discourse Meta 👋

hmmm, that looks similar to these topics, perhaps they can help

> [@Port 443 isn't accessible via hostname](https://meta.discourse.org/t/port-443-isnt-accessible-via-hostname/165163):
>
> Hello! I’ve recently decided to try to install Discourse. Upon getting everything in the folder on Ubuntu 20.4, I’m getting a “Port 443 isn’t accessible via hostname” error. Trying to connect internally and externally won’t work at all. I’ve done a LOT of searching around. I’ve removed proxies via CloudFlare and just flat out reinstalled it multiple times, changing the sub domains, even using the root domain at one point. Nothing has worked. I have confirmed every time that the domain IS poin…

> [@Error - Port 443 not open?](https://meta.discourse.org/t/error-port-443-not-open/238383):
>
> Hi, This is probably a basic Question, but: I’m currently tring to install Discourse onto my Ubunut Server but I always get this Error: My DNS Setting seem correct: How do I fix this? Thanks in advance!

---

<div class="post-metadata">

### Author: ![Ppantaleo](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/ppantaleo/32/370444_2.png) [@Ppantaleo](https://meta.discourse.org/u/Ppantaleo)
#### Post date: [March 13, 2024, 4:51pm UTC](https://meta.discourse.org/t/error-in-install-aws-lightsail-with-cloudflare/299168/3 "2024-03-13T16:51:03Z")

</div>

Thanks Lili, neither of the two threads reports a solution to the problem unfortunately.

---

<div class="post-metadata">

### Author: ![pfaffman](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/pfaffman/32/120154_2.png) [@pfaffman](https://meta.discourse.org/u/pfaffman)
#### Post date: [March 13, 2024, 10:19pm UTC](https://meta.discourse.org/t/error-in-install-aws-lightsail-with-cloudflare/299168/4 "2024-03-13T22:19:16Z")

</div>

Your site is up now, so this is solved?

Did you turn off the orange cloud as the links suggested?
