# Error in installing

**URL:** https://meta.discourse.org/t/error-in-installing/28299
**Category:** Self-hosting
**Created:** [May 4, 2015, 7:31pm UTC](https://meta.discourse.org/t/error-in-installing/28299 "2015-05-04T19:31:05Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![Erik\_Manger](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/erik_manger/32/179399_2.png) [@Erik\_Manger](https://meta.discourse.org/u/Erik_Manger)
#### Post date: [May 4, 2015, 7:31pm UTC](https://meta.discourse.org/t/error-in-installing/28299/1 "2015-05-04T19:31:05Z")

</div>

Hi,

Error response from daemon: Cannot start container app: Error starting userland proxy: listen tcp 0.0.0.0:80: bind: address already in use

What does this mean? I got it after trying to run the application.

---

<div class="post-metadata">

### Author: ![codinghorror](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/codinghorror/32/110067_2.png) [@codinghorror](https://meta.discourse.org/u/codinghorror)
#### Post date: [May 4, 2015, 8:46pm UTC](https://meta.discourse.org/t/error-in-installing/28299/2 "2015-05-04T20:46:36Z")

</div>

You have something occupying port 80 (web traffic, unencrypted) in your host OS. Turn whatever that is, off. (Apache, etc)

---

<div class="post-metadata">

### Author: ![riking](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/riking/32/170938_2.png) [@riking](https://meta.discourse.org/u/riking)
#### Post date: [May 4, 2015, 9:55pm UTC](https://meta.discourse.org/t/error-in-installing/28299/3 "2015-05-04T21:55:45Z")

</div>

> [@Run other websites on the same machine as Discourse](https://meta.discourse.org/t/running-other-websites-on-the-same-machine-as-discourse/17247):
>
> @pfaffman edited this heavily 2022.02.24. Blame me if it’s broken. If you want to run other websites on the same machine as Discourse, you need to set up an extra NGINX or HAProxy proxy in front of the Docker container. NOTE: This is for advanced admins This guide assumes you already have Discourse working - if you don’t, it may be hard to tell whether or not the configuration is working. You cannot use ./discourse-setup to set up Discourse if another server is using port 80 or 443. You will…
