# Error "Killed" while running rake posts:rebake

**URL:** https://meta.discourse.org/t/error-killed-while-running-rake-posts-rebake/111943
**Category:** Self-hosting
**Tags:** server-resources
**Created:** [March 18, 2019, 4:53pm UTC](https://meta.discourse.org/t/error-killed-while-running-rake-posts-rebake/111943 "2019-03-18T16:53:37Z")
**Posts on this page:** 1
**Showing post:** 15

<div class="post-metadata">

### Author: ![Stephen](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/stephen/32/95011_2.png) [@Stephen](https://meta.discourse.org/u/Stephen)
#### Post date: [May 12, 2019, 5:31pm UTC](https://meta.discourse.org/t/error-killed-while-running-rake-posts-rebake/111943/15 "2019-05-12T17:31:45Z")

</div>

That’s it, without a doubt. On 1GB it’s mandatory, on anything more than 1GB it’s only a matter of time before processes are killed when the system runs low on free memory:

> [@Worker process is more than defined?](https://meta.discourse.org/t/worker-process-is-more-than-defined/113230/4):
>
> Our recommended configuration is at least 2G of RAM + 2G of swap.

> [@schleifer](#):
>
> Yeah :arrow_up: that. The linux kernel effectively _demands_ swap be available or OOM killer will wreck your :poop: sooner or later.

The way linux handles memory changes fundamentally if you don’t have swap available. Think of an Android smartphone terminating background processes for hungrier foreground processes.

---

_[View the full topic](https://meta.discourse.org/t/error-killed-while-running-rake-posts-rebake/111943)._
