# Error response on port 443

**URL:** https://meta.discourse.org/t/error-response-on-port-443/64325
**Category:** Support
**Created:** [6월 11, 2017, 8:14오후 UTC](https://meta.discourse.org/t/error-response-on-port-443/64325 "2017-06-11T20:14:33Z")
**Posts on this page:** 5
**Page:** 1

<div class="post-metadata">

### Author: ![danielK](https://avatars.discourse-cdn.com/v4/letter/d/a88e57/32.png) [@danielK](https://meta.discourse.org/u/danielK)
#### Post date: [6월 11, 2017, 8:14오후 UTC](https://meta.discourse.org/t/error-response-on-port-443/64325/1 "2017-06-11T20:14:33Z")

</div>

Hey,

I’m fairly new to discourse but trying to get it running. However, I was able to install a fresh discourse and it worked perfect. After that I imported existing data from an old phpbb platform. This also worked pretty well but after trying to start the app, I received the following error:

```
root@Ubuntu-1604-xenial-64-minimal ~ # /var/discourse/launcher start app

starting up existing container
+ /usr/bin/docker start app
Error response from daemon: driver failed programming external connectivity on endpoint app (968b81cbbd373c581d13a6f733ceba1a3b04aceaf292ecc51141fb26f133c7bf): Bind for 0.0.0.0:443 failed: port is already allocated
Error: failed to start containers: app

```

netstat:

```
root@Ubuntu-1604-xenial-64-minimal ~ # netstat -tulpn
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 0.0.0.0:22 0.0.0.0:* LISTEN 1027/sshd
tcp 0 0 127.0.0.1:5432 0.0.0.0:* LISTEN 17467/postgres
tcp 0 0 127.0.0.1:6379 0.0.0.0:* LISTEN 28390/redis-server
tcp6 0 0 :::22 :::* LISTEN 1027/sshd
tcp6 0 0 :::443 :::* LISTEN 14632/docker-proxy
tcp6 0 0 :::6379 :::* LISTEN 28428/redis-server
tcp6 0 0 :::80 :::* LISTEN 14644/docker-proxy
udp 0 0 0.0.0.0:68 0.0.0.0:* 788/dhclient

```

I had vsftpd and mysql on the server but removed it. Any ideas on how to solve the issue?

Thanks,  
Daniel

---

<div class="post-metadata">

### Author: ![elijah](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/elijah/32/104055_2.png) [@elijah](https://meta.discourse.org/u/elijah)
#### Post date: [6월 11, 2017, 9:34오후 UTC](https://meta.discourse.org/t/error-response-on-port-443/64325/2 "2017-06-11T21:34:28Z")

</div>

According to that netstat output, it is Docker listening on port 443. What else do you have running on this server?

It is possible to run other things besides Discourse on a single machine, but it is not recommended.

---

<div class="post-metadata">

### Author: ![danielK](https://avatars.discourse-cdn.com/v4/letter/d/a88e57/32.png) [@danielK](https://meta.discourse.org/u/danielK)
#### Post date: [6월 11, 2017, 9:59오후 UTC](https://meta.discourse.org/t/error-response-on-port-443/64325/3 "2017-06-11T21:59:20Z")

</div>

I’m not sure about other running services, but the service status list looks as follows

```
root@Ubuntu-1604-xenial-64-minimal ~ # service --status-all
 [-] apparmor
 [+] atd
 [-] bootmisc.sh
 [-] cgroupfs-mount
 [-] checkfs.sh
 [-] checkroot-bootclean.sh
 [-] checkroot.sh
 [+] console-setup
 [+] cpufrequtils
 [+] cron
 [+] dbus
 [+] docker
 [+] fail2ban
 [+] grub-common
 [+] haveged
 [-] hostname.sh
 [-] hwclock.sh
 [-] keyboard-setup.dpkg-bak
 [-] killprocs
 [+] kmod
 [+] loadcpufreq
 [-] lvm2
 [+] lvm2-lvmetad
 [+] lvm2-lvmpolld
 [+] mdadm
 [-] mdadm-waitidle
 [-] mountall-bootclean.sh
 [-] mountall.sh
 [-] mountdevsubfs.sh
 [-] mountkernfs.sh
 [-] mountnfs-bootclean.sh
 [-] mountnfs.sh
 [+] networking
 [+] ondemand
 [+] postgresql
 [+] procps
 [+] rc.local
 [+] redis-server
 [-] rsync
 [+] rsyslog
 [-] sendsigs
 [+] ssh
 [-] sysstat
 [+] udev
 [-] umountfs
 [-] umountnfs.sh
 [-] umountroot
 [+] unattended-upgrades
 [+] urandom
 [-] uuidd
 [-] vsftpd

```

I don’t want to have anything running besides docker.

---

<div class="post-metadata">

### Author: ![danielK](https://avatars.discourse-cdn.com/v4/letter/d/a88e57/32.png) [@danielK](https://meta.discourse.org/u/danielK)
#### Post date: [6월 11, 2017, 11:13오후 UTC](https://meta.discourse.org/t/error-response-on-port-443/64325/4 "2017-06-11T23:13:53Z")

</div>

solved it! a simple reboot did the trick…

---

<div class="post-metadata">

### Author: ![sam](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/sam/32/102149_2.png) [@sam](https://meta.discourse.org/u/sam)
#### Post date: [6월 12, 2017, 3:36오후 UTC](https://meta.discourse.org/t/error-response-on-port-443/64325/5 "2017-06-12T15:36:36Z")

</div>


