# Error starting userland proxy: listen tcp4 0.0.0.0:443: bind: address already in use

**URL:** https://meta.discourse.org/t/error-starting-userland-proxy-listen-tcp4-0-0-0-0-bind-address-already-in-use/183283
**Category:** Self-hosting
**Created:** [March 15, 2021, 9:53am UTC](https://meta.discourse.org/t/error-starting-userland-proxy-listen-tcp4-0-0-0-0-bind-address-already-in-use/183283 "2021-03-15T09:53:04Z")
**Posts on this page:** 5
**Page:** 1

<div class="post-metadata">

### Author: ![Andrea\_Giovacchini](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/andrea_giovacchini/32/213224_2.png) [@Andrea\_Giovacchini](https://meta.discourse.org/u/Andrea_Giovacchini)
#### Post date: [March 15, 2021, 9:53am UTC](https://meta.discourse.org/t/error-starting-userland-proxy-listen-tcp4-0-0-0-0-bind-address-already-in-use/183283/1 "2021-03-15T09:53:04Z")

</div>

Well, I’d like to give Discourse a try so I’m installing it via docker, but I get this error. Actually by searching I see lots of people gets this error, but I can’t figure out how to solve it.

```
starting up existing container

    + /usr/bin/docker start app

    Error response from daemon: driver failed programming external connectivity on endpoint app (7336c875bdf9e3f18f08ca0af0a5aad10181ba37508f92c68f87a75637c56583): Error starting userland proxy: listen tcp4 0.0.0.0:443: bind: address already in use

    Error: failed to start containers: app

```

Have alredy set this in /opt/discourse/containers/app.yml  
expose:

- “8880:80” # http
- “8443:443” # https

It is a web server where I have a website running on Apache with https so yes, port 443 is already in use, but if I set app.yml to remap 443 to 8443, why am I still getting it?

---

<div class="post-metadata">

### Author: ![pfaffman](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/pfaffman/32/120154_2.png) [@pfaffman](https://meta.discourse.org/u/pfaffman)
#### Post date: [March 15, 2021, 10:02am UTC](https://meta.discourse.org/t/error-starting-userland-proxy-listen-tcp4-0-0-0-0-bind-address-already-in-use/183283/2 "2021-03-15T10:02:32Z")

</div>

You should see [Discourse official Standard Installation](https://meta.discourse.org/t/discourse-official-standard-installation/142537) and [How to set up Discourse on a server with existing Apache sites](https://meta.discourse.org/t/how-to-set-up-discourse-on-a-server-with-existing-apache-sites/30013).

Judging from the path you include, You might also check [Troubleshooting Bitnami Installations](https://meta.discourse.org/t/troubleshooting-bitnami-installations/142538)

---

<div class="post-metadata">

### Author: ![Andrea\_Giovacchini](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/andrea_giovacchini/32/213224_2.png) [@Andrea\_Giovacchini](https://meta.discourse.org/u/Andrea_Giovacchini)
#### Post date: [March 15, 2021, 10:28am UTC](https://meta.discourse.org/t/error-starting-userland-proxy-listen-tcp4-0-0-0-0-bind-address-already-in-use/183283/3 "2021-03-15T10:28:05Z")

</div>

I’ve seen that document but shouldn’t changing the app.yml have an effect on the ports used or is it ignored? Discourse is the first app I try with some kind of “hard-coded” port I can’t change.

I really don’t like to put another piece of software between my customers and my website which is happily up and running, I’d rather map in Apache a subdomain to discourse

And what if I get another application which behaves like this and is forced to run on port 443?

---

<div class="post-metadata">

### Author: ![pfaffman](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/pfaffman/32/120154_2.png) [@pfaffman](https://meta.discourse.org/u/pfaffman)
#### Post date: [March 15, 2021, 7:08pm UTC](https://meta.discourse.org/t/error-starting-userland-proxy-listen-tcp4-0-0-0-0-bind-address-already-in-use/183283/4 "2021-03-15T19:08:36Z")

</div>

> [@Andrea\_Giovacchini](#):
>
> shouldn’t changing the app.yml have an effect on the ports used

Yes, but you have to `./launcher rebuild app` (or maybe `./launcher destroy app;./launcher start app`). My guess is that you just edited the file and then restarted the container that already had the ports configured.

---

<div class="post-metadata">

### Author: ![system](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/system/32/443519_2.png) [@system](https://meta.discourse.org/u/system)
#### Post date: [April 14, 2021, 7:09pm UTC](https://meta.discourse.org/t/error-starting-userland-proxy-listen-tcp4-0-0-0-0-bind-address-already-in-use/183283/5 "2021-04-14T19:09:25Z")

</div>

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.
