Error upgrading Discourse


(Aaron Shafovaloff) #1

The last part of the logs:

Compressing: pretty-text-bundle-2c11f6ae96b29009d618e92aa3c70ca6405a230487f7e95d6b8bbea5dd2df139.js
uglifyjs '/var/www/discourse/public/assets/_pretty-text-bundle-2c11f6ae96b29009d618e92aa3c70ca6405a230487f7e95d6b8bbea5dd2df139.js' -p relative -c -m -o '/var/www/discourse/public/assets/pretty-text-bundle-2c11f6ae96b29009d618e92aa3c70ca6405a230487f7e95d6b8bbea5dd2df139.js' --source-map-root '/assets' --source-map '/var/www/discourse/public/assets/pretty-text-bundle-2c11f6ae96b29009d618e92aa3c70ca6405a230487f7e95d6b8bbea5dd2df139.js.map' --source-map-url '/assets/pretty-text-bundle-2c11f6ae96b29009d618e92aa3c70ca6405a230487f7e95d6b8bbea5dd2df139.js.map'
Killed

Any ideas? Thanks!


(Jeff Atwood) #2

Out of memory, make sure you have 2GB swap.

Upgrade from command line, SSH into your server and run:

cd /var/discourse
git pull
./launcher rebuild app

(Aaron Shafovaloff) #3

This combined with a few other things (found elsewhere on this forum) did the trick. Thank you!

apt-get autoclean
apt-get autoremove
git pull
./launcher cleanup
./launcher rebuild app
./launcher cleanup