Error when pressing password reset button


(kushagra) #1

i have started my own Forum ask.bloggingstandard.com but users can not reset password


(Jeff Atwood) #2

Sounds like your email setup is not working? If you go to Admin, Email, send test email do you get it?


(kushagra) #3

ya its working perfectly. i have also tested it on mail-tester.com


(Jeff Atwood) #4

So the mail is being sent but it is not arriving in users mailboxes? That points to a deliverability problem.


(kushagra) #5

i dont think so because when i tested resetting password then i putted username and clicked reset password but the option reset password not working


(kushagra) #6


(Jeff Atwood) #7

Is there anything in /logs in your browser? Try clearing logs, then pressing that button to see if any error appears in logs related to the button action.


(kushagra) #8

I have cleared all the logs ,cache and all but not working


(Jay Pfaffman) #9

I’ve seen something like this lately. Mail tests work, but mail doesn’t go out. No errors in discourse, no logs at mailgun.

If seems like a sidekiq problem. I think they sometimes, a restart will help.


(Jay Pfaffman) #10

Update: The site I was thinking about was still not sending mail (it’s been up for nearly a month and they’ve been having this problem the whole time, best I can tell). I did a ./launcher rebuild app and am hoping that this will solve whatever problem that might actually have been fixed.

Is there some easy way that a Normal Person can see that Sidekiq is working correctly? There’s no link to it anywhere, is there? That’s https://forum.example.com/sidekiq/ if you’re looking for it.