Error when updating Discourse to 2.2.0.beta3


(Florian) #1

I’ve used the upgrade wizard trying to update to 2.2.0.beta3. The docker_manager was updated without problems but for discourse the upgrade stalls after some time:

Any ideas?


(Florian) #2

After the updating the docker_manager I went back to the main page of the update wizard by clicking the Discourse logo. This listed the other packages to be updated and I’ve clicked “Upgrade all” (also tried with discourse only).

However, after I’ve went to the upgrade URL directly, I got the message to perform an update of the base image via

cd /var/discourse
git pull
./launcher rebuild app

At the end of that process, I got

Removing old container
+ /usr/bin/docker rm app
Error response from daemon: Driver aufs failed to remove root filesystem fda9c2792b674636b4b20af9e8c98b49f2a90744a601d17e50af44b15e96b47d: rename /var/lib/docker/aufs/mnt/c583aa974047f6ab81c6d0c467350ffcca1bea2d4fe3f9e3f387a624d6dd814e /var/lib/docker/aufs/mnt/c583aa974047f6ab81c6d0c467350ffcca1bea2d4fe3f9e3f387a624d6dd814e-removing: device or resource busy

starting up existing container
+ /usr/bin/docker start app
Error response from daemon: Container is marked for removal and cannot be started.
Error: failed to start containers: app

I needed to restart the server, perform the rebuild again and then it worked.


(Ridha) #3

Glad to found this clue.

I got an error too when upgrade to 2.2.0.beta3
When upgrading Docker Manager process my computer suddenly restart. :cry:

Then, after I enter the website.com/admin/upgrade, I found a same message.

I thought, I only need to restore droplet (Digital Ocean) from the weekly back up feature just like my previous case. The last back up is 5 days ago. But, its getting worse, the web is not accessible. :sob::sob::sob:

After 6 hours struggling to safe my droplet and avoiding build a new discourse again for several times again, I tried to enter my SSH and do this command:

sudo shutdown -r now Restart the server
cd /var/discourse
./launcher rebuild app

And its live again. :grinning:
And half of my life safe again. :face_with_head_bandage:


(Jay Pfaffman) #4

Why did you not think to do what the message told you to do?


(Dmitry Suzdalev) #5

Now I wonder should I upgrade from beta2 to beta3 or will I get the same error?

Also, if I decide to risk it, it seems like I should do a manual rebuild after rebooting the server, rather then starting it, seeing it fail and then rebooting and repeating. Am I right here? :slight_smile:


(Jeff Atwood) #6

I had this too, but trying again in the web UI worked fine. It seems to have a lot of trouble wth the step where it is “waiting on unicorn to reload.” cc @tgxworld


(Alan Tan) #8

Do you mean it stalled during the web upgrade or is it

@dimsuz There is no need to restart the server here. You’ll be prompted to do a ./launcher rebuild because of a recent change in the base image.


(Ridha) #9

I am panic at that time. So I forget to record the message. This is my first try to restore my droplet backup from weekly backup. However, I am happy my site is in good condition now.


(Jay Pfaffman) #10

I see. Next time, just log in and type the commands that it tells you! :wink: