Error while Bootstrapping Launcher


(Jonathan Juan) #1

Whenever I try to bootstrap the launcher I get the following error:

FAILED
--------------------
RuntimeError: socat /dev/null UNIX-CONNECT:/shared/postgres_run/.s.PGSQL.5432 || exit 0 && echo postgres already running stop container ; exit 1 failed with return #<Process::Status: pid 53 exit 1>
Location of failure: /pups/lib/pups/exec_command.rb:85:in `spawn'
exec failed with the params "socat /dev/null UNIX-CONNECT:/shared/postgres_run/.s.PGSQL.5432 || exit 0 && echo postgres already running stop container ; exit 1"
5ee90f5d5f9c429594d75bae29d036ca5cd00576cbd183e0ff668467ef3c4284
FAILED TO BOOTSTRAP

What should I do to fix this? I’ve already tried rebooting my docklet with Digital Ocean.


(Jeff Atwood) #2

Per this topic it sounds like rebooting is in order?


(Jonathan Juan) #3

How do I go about doing that?


(Sam Saffron) #4

there is an option in the digital ocean dashboard

or you can type reboot


(Jonathan Juan) #5

I tried it both from the Digital Ocean dashboard and from the console, and the same error still applies.


Cannot rebuild following site failure: "postgres already running"
(Sam Saffron) #6

Is anything running? what does docker ps return? If anything try running docker kill on it.


(Jonathan Juan) #7
root@discourse:/var/discourse# docker ps
CONTAINER ID        IMAGE                        COMMAND             CREATED             STATUS              PORTS                                      NAMES
b7b99bb6d301        local_discourse/app:latest   "/sbin/runit"       14 minutes ago      Up 14 minutes       0.0.0.0:80->80/tcp, 0.0.0.0:2222->22/tcp   app

(Sam Saffron) #8

So … it appears to be running, what is the issue ?

If you need rebuild … ./launcher rebuild app


(Jonathan Juan) #9

To be honest, the “real” problem is that clicking on any topic on the forum returns “The page you requested doesn’t exist or is private.” The last time this happened, I was able to fix it by using ./launcher bootstrap app. I just kind of figured that because this error didn’t show up last time, that it was the problem that needed to be addressed.

I have done ./launcher rebuild app (both before and after I did the reboot), and that seems to go through with no errors, but the problem still persists.


(Sam Saffron) #10

is this the lego forum? bootstrap should fix it if its code related.

have a look in yoursitename.com/logs are you noticing any errors there. This could be config related.


(Jonathan Juan) #11

You were right; it was related to a plugin that became out of date when we upgraded. I should’ve checked those first. Editing out the plugin out of app.yml and rebuilding it fixed it for me. Thanks for being so patient with me, I know I’ve made quite a lot of simple mistakes lately.


(Sam Saffron) #12

Which plugin is this? We need to flag it so others are not bitten


(Jonathan Juan) #13

It was Tagger. I’m not sure of the problem directly, but all of the error logs were related to it, and when I removed it, the forums went back to working. It might have been conflict with another plugin or the plugin itself.


(Kane York) #14

Did you run the full install instructions, namely this part?

rake tagger:install:migrations
rake db:migrate SCOPE=tagger

(Sam Saffron) #15

We need to fix this at the extensibility level, this should happen automatically.