Error while cloning git on Ubuntu 18.04

While I was installing discourse on my Ubuntu server I keep getting this error every time I try to clone the git

Cloning into '/var/discourse'...
fatal: unable to access 'https://github.com/discourse/discourse_docker.git/': gnutls_handshake() failed: Error in the pull function.

Are you running behind a proxy?

If you run curl in some random https web page does it work?

E.g., if you run:

curl https://meta.discourse.org/t/error-while-cloning-git-on-ubuntu-18-04/124565

do you see the HTML of this page?

4 Likes

I’ve actually gotten past this issue now, but I keep getting a bootstrap error after setting up. Also I don’t see the HTML would this have anything to do with using cloudflare?

We definitely recommend bypassing all CloudFlare proxying. It is fine to use CloudFlare for DNS entries of course.

2 Likes

How would I go about bypassing those proxy’s, sorry for all the questions I’m just new to this.

Turn off the orange cloud indicator. You want to bypass CloudFlare functionality, as it is not needed. The cloud indicator should be grey not orange.

1 Like

Alright great! I’ll try that now.

Yep that’s not related to Cloudflare. Cloudflare sits between client and server, not server and cloud.

Yeah, do you know what might be causing this and any solution?

Your docker container can’t access the internet.

Is your server in some sort of constrained environment? Enterprise setup? Intranet? Internet uses a proxy?

3 Likes

Does you machine have some sort of constraint in the outbound rules?

For example, in AWS you have all outbound traffic allowed by default in the security groups.

In Digital Ocean you use Firewalls, the default inbound rule is SSH and the default outbound rule is to Permit All Traffic.

Did you removed any of these outbound rules?

Things to consider:

  • Where is your server hosted?
  • What are the outbound rules?
  • If you try to curl a site with https does it work?
  • If you try to curl a site with http only (not https) does it work? (to know if the issue is in the SSL connection)
  • Have you changed /etc/resolv.conf or some similar file that deals with DNS?
1 Like

I just reset my VPS to see if any of this can get resolved