Error while installing discourse-oauth2-basic plugin

Can u help me to install discourse-oauth2-basic plugin…it’s giving error while:

  • exec:
    cd: $home
    hook: bundle_exec
    cmd:
    - su discourse -c ‘bundle install --deployment --verbose --without test --without development’
    - su discourse -c ‘bundle exec rake db:migrate
    - su discourse -c ‘bundle exec rake assets:precompile

executing this command…

1 Like

What version of Discourse are you using?

1 Like

Discourse Version - v1.9.0.beta13 +136
My older discourse server is already working on this version only…

That version is from 2017, is unsupported, and has numerous security vulnerabilities. You should update to a supported version ASAP.

3 Likes

after update it will work…

The discourse-oauth2-basic plugin is compatible with the latest version of Discourse, yes

5 Likes

how to upgrade discourse…via UI its disabled…

Rebuild from the command prompt.

If you are using docker: from the discourse directory initiate:

./launcher rebuild app

If you are on a non-docker setup then following might help:

git pull
bundle install
bundle exec rake db:migrate
1 Like

i am on a Docker setup…with three containers…Redis, App and Data…

This Topic may be some additional help, good luck!: