Error while moving first post of topic to another topic


(Thorben Egberts) #1

Hi there,

our non-admins and non-moderators are experiencing an issue while moving the first post of a topic to an existing topic:

(Also it’s a bit odd that the failure message is shown with green background)

I tried it myself as a moderator and admin. It worked and I got no message like that. My colleagues say it’s happening since the last version bump.


(Jeff Atwood) #2

How are they moving without Staff status? Are they trust level 4?


(Rafael dos Santos Silva) #3

This happened with me when trying to move to a topic that was getting constant posting. Just clicking the move button again (sometimes multiple times) and it works.

Maybe it bugs out if a post is inserted between the search and the move?


(Thorben Egberts) #4

Nope, there where no other posts at the time.


(Thorben Egberts) #5

Jep, they are trust level 4.


(Jeff Atwood) #6

Ok can you repro this @eviltrout with tl4 users?


(Robin Ward) #7

Looks like there were validation errors for a TL4 error moving a post. Since the post has already been validated I skip them during the moving phase and that seems to fix it:


(Peter Bäckgren) #8

Even if old this seems to be the most relevant topic. A few more listed last.

A topic had it’s two first posts posted out of order. Could not find a way to bump the 2nd post to the top.

Moved away the first post to a an old topic and then moved it back to get it as the last post. Getting it last this way kinda worked… but…

…moving away the first post destroyed the entire topic so that it was not visible at all.

Ended up recreating the topic and reposting contents manually.

Simply could not figure out a way to move posts up (or down) in the time chain.

Sometimes this could come in handy, especially if someone summarizes a topic very well and you want to wikitize that post to the top, i.e. handling of the topic is almost complete but you still want to show the reasoning for people later.

So, am I missing something here? No way to “bump” posts? Changing the timestamp only seems to be for the topic but haven’t tried everything else I can think of yet.