Error While Trying To Start Launcher


(Zack) #1

Hello, im trying to install Discourse on Ubuntu Server, however ive been getting this error all night and I cant seem to fix it. I have tried multiple tutorials and multiple reinstalls of Ubuntu to see if I can fix it, nothing seems to be working. Here is the error I am getting:

root@ubuntu:/var/docker# ./launcher start app
WARNING: No swap limit support
No cid found, creating a new container
Calculated ENV: -e LANG=en_US.UTF-8 -e RAILS_ENV=production -e UNICORN_WORKERS=3 -e UNICORN_SIDEKIQS=1 -e RUBY_GC_MALLOC_LIMIT=40000000 -e RUBY_HEAP_MIN_SLOTS=800000 -e DISCOURSE_DB_SOCKET=/var/run/postgresql -e DISCOURSE_DB_HOST= -e DISCOURSE_DB_PORT= -e HOME=/root -e DISCOURSE_DEVELOPER_EMAILS=zelakto@zelakto.tv -e DISCOURSE_HOSTNAME=community.zelakto.tv -e DISCOURSE_SMTP_ADDRESS=smtp.googlemail.com
Unable to find image 'local_discourse/app' locally
Pulling repository local_discourse/app
2014/09/28 02:12:54 Error: image local_discourse/app not found
root@ubuntu:/var/docker#

A fast solution to this would be amazing, thank you for your time. <3


(Sam Saffron) #2

Try

./launcher rebuild app


(Zack) #3

Thanks, but I have already tried this countless times.


(Sam Saffron) #4

What does docker info and docker images return


(Zack) #5

Here is what both of them say.

http://i.gyazo.com/bf832e6c33260a14ee95695a0fa27fd0.png and http://i.gyazo.com/5d2ba5888f9d9b7c6f07973ae7fdc6a8.png


(Jeff Atwood) #6

What about docker version? You can just highlight the text in putty then paste it here, screenshots are more work for everyone and cannot be indexed properly by Google.


(Zack) #7

My docker version is:

Client version: 1.2.0
Client API version: 1.14
Go version (client): go1.3.1
Git commit (client): fa7b24f
OS/Arch (client): linux/amd64
Server version: 1.2.0
Server API version: 1.14
Go version (server): go1.3.1
Git commit (server): fa7b24f

I actually figured out the problem. (Im using a 8gb usb for testing, and it ran out of space, im stupid) Haha. Thanks for your time.


(Jeff Atwood) #9