# Errori su un forum a cui partecipo volontariamente

**URL:** https://meta.discourse.org/t/errors-on-a-forum-i-volunteer-with/284654
**Category:** Support
**Created:** [7 Novembre 2023, 2:40am UTC](https://meta.discourse.org/t/errors-on-a-forum-i-volunteer-with/284654 "2023-11-07T02:40:34Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![sunjam](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/sunjam/32/175682_2.png) [@sunjam](https://meta.discourse.org/u/sunjam)
#### Post date: [7 Novembre 2023, 2:40am UTC](https://meta.discourse.org/t/errors-on-a-forum-i-volunteer-with/284654/1 "2023-11-07T02:40:34Z")

</div>

Ciao a tutti, sono un amministratore volontario di questo forum e stiamo riscontrando molti errori 429, email perse e altri problemi. Ho notato che Sidekiq ha bisogno di più memoria rispetto ai 500 MB attuali e sembra anche che il server di posta abbia esaurito lo spazio nella coda. Non sono sicuro di quali altri problemi esistano, dato che non ho accesso al server sottostante, ma spero che altri possano offrire suggerimenti. Grazie!

> **Discourse::InvalidParameters (string contains null byte) app/controllers/application\_controller.rb:134:in \`block in \<class:ApplicationController\>' lib/middleware/omniauth\_bypass\_middleware.rb:74:in \`c**
>
> Messaggio (919 copie riportate)
> 
> Discourse::InvalidParameters (string contains null byte)  
> app/controllers/application\_controller.rb:134:in `block in <class:ApplicationController>' lib/middleware/omniauth_bypass_middleware.rb:74:in `call’  
> lib/content\_security\_policy/middleware.rb:12:in `call' lib/middleware/anonymous_cache.rb:387:in `call’  
> lib/middleware/gtm\_script\_nonce\_injector.rb:10:in `call' config/initializers/100-quiet_logger.rb:20:in `call’  
> config/initializers/100-silence\_logger.rb:29:in `call' lib/middleware/enforce_hostname.rb:24:in `call’  
> lib/middleware/request\_tracker.rb:233:in `call’
> 
> Backtrace
> 
> app/controllers/application\_controller.rb:134:in `block in <class:ApplicationController>' activesupport (7.0.7) lib/active_support/rescuable.rb:116:in `instance\_exec’  
> activesupport (7.0.7) lib/active\_support/rescuable.rb:116:in `block in handler_for_rescue' activesupport (7.0.7) lib/active_support/rescuable.rb:92:in `rescue\_with\_handler’  
> activesupport (7.0.7) lib/active\_support/rescuable.rb:165:in `rescue_with_handler' actionpack (7.0.7) lib/action_controller/metal/rescue.rb:26:in `rescue in process\_action’  
> actionpack (7.0.7) lib/action\_controller/metal/rescue.rb:22:in `process_action' actionpack (7.0.7) lib/action_controller/metal/instrumentation.rb:67:in `block in process\_action’  
> activesupport (7.0.7) lib/active\_support/notifications.rb:206:in `block in instrument' activesupport (7.0.7) lib/active_support/notifications/instrumenter.rb:24:in `instrument’

> **Job exception: execution expired**
>
> Messaggio (1704 copie riportate)
> 
> Eccezione del job: execution expired
> 
> Backtrace
> 
> /var/www/discourse/vendor/bundle/ruby/3.2.0/gems/net-smtp-0.4.0/lib/net/smtp.rb:631:in `initialize' /var/www/discourse/vendor/bundle/ruby/3.2.0/gems/net-smtp-0.4.0/lib/net/smtp.rb:631:in `open’  
> /var/www/discourse/vendor/bundle/ruby/3.2.0/gems/net-smtp-0.4.0/lib/net/smtp.rb:631:in `tcp_socket' /var/www/discourse/vendor/bundle/ruby/3.2.0/gems/net-smtp-0.4.0/lib/net/smtp.rb:641:in `block in do\_start’  
> /var/www/discourse/vendor/bundle/ruby/3.2.0/gems/timeout-0.4.0/lib/timeout.rb:186:in `block in timeout' /var/www/discourse/vendor/bundle/ruby/3.2.0/gems/timeout-0.4.0/lib/timeout.rb:193:in `timeout’  
> /var/www/discourse/vendor/bundle/ruby/3.2.0/gems/net-smtp-0.4.0/lib/net/smtp.rb:640:in `do_start' /var/www/discourse/vendor/bundle/ruby/3.2.0/gems/net-smtp-0.4.0/lib/net/smtp.rb:610:in `start’  
> /var/www/discourse/vendor/bundle/ruby/3.2.0/gems/mail-2.8.1/lib/mail/network/delivery\_methods/smtp.rb:109:in `start_smtp_session' /var/www/discourse/vendor/bundle/ruby/3.2.0/gems/mail-2.8.1/lib/mail/network/delivery_methods/smtp.rb:100:in `deliver!’

> **Job exception: Net::ReadTimeout**
>
> Messaggio (75565 copie riportate)  
> Eccezione del job: Net::ReadTimeout  
> Backtrace
> 
> /usr/local/lib/ruby/3.2.0/net/protocol.rb:229:in `rbuf_fill' /usr/local/lib/ruby/3.2.0/net/protocol.rb:199:in `readuntil’  
> /usr/local/lib/ruby/3.2.0/net/protocol.rb:377:in `each_message_chunk' /var/www/discourse/vendor/bundle/ruby/3.2.0/gems/net-pop-0.1.2/lib/net/pop.rb:958:in `block in retr’  
> /var/www/discourse/vendor/bundle/ruby/3.2.0/gems/net-pop-0.1.2/lib/net/pop.rb:1016:in `critical' /var/www/discourse/vendor/bundle/ruby/3.2.0/gems/net-pop-0.1.2/lib/net/pop.rb:956:in `retr’  
> /var/www/discourse/vendor/bundle/ruby/3.2.0/gems/net-pop-0.1.2/lib/net/pop.rb:810:in `pop' /var/www/discourse/app/jobs/scheduled/poll_mailbox.rb:47:in `block (2 levels) in poll\_pop3’  
> /var/www/discourse/vendor/bundle/ruby/3.2.0/gems/net-pop-0.1.2/lib/net/pop.rb:669:in `each' /var/www/discourse/vendor/bundle/ruby/3.2.0/gems/net-pop-0.1.2/lib/net/pop.rb:669:in `each\_mail’

> **Job exception: X-MS-Exchange-CrossTenant-FromEntityHeader: Internet**
>
> Eccezione del job: X-MS-Exchange-CrossTenant-FromEntityHeader: Internet  
> Backtrace
> 
> /var/www/discourse/vendor/bundle/ruby/3.2.0/gems/net-pop-0.1.2/lib/net/pop.rb:1004:in `check_response' /var/www/discourse/vendor/bundle/ruby/3.2.0/gems/net-pop-0.1.2/lib/net/pop.rb:984:in `quit’  
> /var/www/discourse/vendor/bundle/ruby/3.2.0/gems/net-pop-0.1.2/lib/net/pop.rb:603:in `do_finish' /var/www/discourse/vendor/bundle/ruby/3.2.0/gems/net-pop-0.1.2/lib/net/pop.rb:533:in `ensure in start’  
> /var/www/discourse/vendor/bundle/ruby/3.2.0/gems/net-pop-0.1.2/lib/net/pop.rb:533:in `start' /var/www/discourse/app/jobs/scheduled/poll_mailbox.rb:45:in `poll\_pop3’  
> /var/www/discourse/app/jobs/scheduled/poll\_mailbox.rb:14:in `execute' /var/www/discourse/app/jobs/base.rb:292:in `block (2 levels) in perform’  
> /var/www/discourse/vendor/bundle/ruby/3.2.0/gems/rails\_multisite-5.0.0/lib/rails\_multisite/connection\_management.rb:82:in `with_connection' /var/www/discourse/app/jobs/base.rb:279:in `block in perform’

> **Job exception: Received-SPF: None (no SPF record) ...\<UNKNOWN\>**
>
> Messaggio (4 copie riportate)  
> Eccezione del job: Received-SPF: None (no SPF record) identity=helo; client-ip=…; envelope-from=\<\>; receiver=  
> Backtrace
> 
> /var/www/discourse/vendor/bundle/ruby/3.2.0/gems/net-pop-0.1.2/lib/net/pop.rb:1004:in `check_response' /var/www/discourse/vendor/bundle/ruby/3.2.0/gems/net-pop-0.1.2/lib/net/pop.rb:984:in `quit’  
> /var/www/discourse/vendor/bundle/ruby/3.2.0/gems/net-pop-0.1.2/lib/net/pop.rb:603:in `do_finish' /var/www/discourse/vendor/bundle/ruby/3.2.0/gems/net-pop-0.1.2/lib/net/pop.rb:533:in `ensure in start’  
> /var/www/discourse/vendor/bundle/ruby/3.2.0/gems/net-pop-0.1.2/lib/net/pop.rb:533:in `start' /var/www/discourse/app/jobs/scheduled/poll_mailbox.rb:45:in `poll\_pop3’  
> /var/www/discourse/app/jobs/scheduled/poll\_mailbox.rb:14:in `execute' /var/www/discourse/app/jobs/base.rb:292:in `block (2 levels) in perform’  
> /var/www/discourse/vendor/bundle/ruby/3.2.0/gems/rails\_multisite-5.0.0/lib/rails\_multisite/connection\_management.rb:82:in `with_connection' /var/www/discourse/app/jobs/base.rb:279:in `block in perform’

> **Job exception: could not obtain a connection from the pool within 5.000 seconds (waited 5.000 seconds); all pooled connections were in use**
>
> Messaggio (92 copie riportate)  
> Eccezione del job: could not obtain a connection from the pool within 5.000 seconds (waited 5.000 seconds); all pooled connections were in use  
> Backtrace
> 
> > **Job exception: by mx with LMTP**
> >
> > Messaggio  
> > Eccezione del job: by mx with LMTP  
> > Backtrace  
> > /var/www/discourse/vendor/bundle/ruby/3.2.0/gems/net-pop-0.1.2/lib/net/pop.rb:1004:in `check_response' /var/www/discourse/vendor/bundle/ruby/3.2.0/gems/net-pop-0.1.2/lib/net/pop.rb:984:in `quit’  
> > /var/www/discourse/vendor/bundle/ruby/3.2.0/gems/net-pop-0.1.2/lib/net/pop.rb:603:in `do_finish' /var/www/discourse/vendor/bundle/ruby/3.2.0/gems/net-pop-0.1.2/lib/net/pop.rb:533:in `ensure in start’  
> > /var/www/discourse/vendor/bundle/ruby/3.2.0/gems/net-pop-0.1.2/lib/net/pop.rb:533:in `start' /var/www/discourse/app/jobs/scheduled/poll_mailbox.rb:45:in `poll\_pop3’  
> > /var/www/discourse/app/jobs/scheduled/poll\_mailbox.rb:14:in `execute' /var/www/discourse/app/jobs/base.rb:292:in `block (2 levels) in perform’  
> > /var/www/discourse/vendor/bundle/ruby/3.2.0/gems/rails\_multisite-5.0.0/lib/rails\_multisite/connection\_management.rb:82:in `with_connection' /var/www/discourse/app/jobs/base.rb:279:in `block in perform’
> 
> /var/www/discourse/vendor/bundle/ruby/3.2.0/gems/activerecord-7.0.7/lib/active\_record/connection\_adapters/abstract/connection\_pool/queue.rb:126:in `block in wait_poll' /var/www/discourse/vendor/bundle/ruby/3.2.0/gems/activerecord-7.0.7/lib/active_record/connection_adapters/abstract/connection_pool/queue.rb:115:in `loop’  
> /var/www/discourse/vendor/bundle/ruby/3.2.0/gems/activerecord-7.0.7/lib/active\_record/connection\_adapters/abstract/connection\_pool/queue.rb:115:in `wait_poll' /var/www/discourse/vendor/bundle/ruby/3.2.0/gems/activerecord-7.0.7/lib/active_record/connection_adapters/abstract/connection_pool/queue.rb:76:in `internal\_poll’  
> /var/www/discourse/vendor/bundle/ruby/3.2.0/gems/activerecord-7.0.7/lib/active\_record/connection\_adapters/abstract/connection\_pool/queue.rb:202:in `internal_poll' /var/www/discourse/vendor/bundle/ruby/3.2.0/gems/activerecord-7.0.7/lib/active_record/connection_adapters/abstract/connection_pool/queue.rb:71:in `block in poll’  
> /usr/local/lib/ruby/3.2.0/monitor.rb:202:in `synchronize' /usr/local/lib/ruby/3.2.0/monitor.rb:202:in `mon\_synchronize’  
> /var/www/discourse/vendor/bundle/ruby/3.2.0/gems/activerecord-7.0.7/lib/active\_record/connection\_adapters/abstract/connection\_pool/queue.rb:80:in `synchronize' /var/www/discourse/vendor/bundle/ruby/3.2.0/gems/activerecord-7.0.7/lib/active_record/connection_adapters/abstract/connection_pool/queue.rb:71:in `poll’

> **Failed to send push notification : Timeout::Error : Timeout::Error**
>
> Messaggio (52 copie riportate)  
> Invio notifica push non riuscito: Timeout::Error : Timeout::Error  
> Backtrace
> 
> /var/www/discourse/lib/final\_destination/resolver.rb:31:in `block in lookup' /var/www/discourse/lib/final_destination/resolver.rb:8:in `synchronize’  
> /var/www/discourse/lib/final\_destination/resolver.rb:8:in `lookup' /var/www/discourse/lib/final_destination/ssrf_detector.rb:127:in `lookup\_ips’  
> /var/www/discourse/lib/final\_destination/ssrf\_detector.rb:95:in `lookup_and_filter_ips' /var/www/discourse/lib/final_destination/http.rb:13:in `connect’  
> /usr/local/lib/ruby/3.2.0/net/http.rb:1248:in `do_start' /usr/local/lib/ruby/3.2.0/net/http.rb:1237:in `start’  
> /usr/local/lib/ruby/3.2.0/net/http.rb:1817:in `request' /var/www/discourse/vendor/bundle/ruby/3.2.0/gems/rack-mini-profiler-3.1.1/lib/patches/net_patches.rb:19:in `block in request\_with\_mini\_profiler’

[details=" NoMethodError (undefined method `downcase’ for #\<ActionController::Parameters {“ **proto** ”=\>{“expect”=\>“100-continue”}, “constructor”=\>{“prototype”=\>{“expect”=\>“100-continue”}}} permitted: false\>) app "]  
Messaggio (65 copie riportate)

> **Failed to handle exception in exception app middleware : ActionController::UnfilteredParameters : unable to convert unpermitted parameters to hash**
>
> Messaggio (167 copie riportate)
> 
> Gestione dell’eccezione nel middleware dell’app non riuscita: ActionController::UnfilteredParameters : impossibile convertire parametri non permessi in hash
> 
> Backtrace
> 
> actionpack-7.0.7/lib/action\_controller/metal/strong\_parameters.rb:289:in `to_h' actionpack-7.0.7/lib/action_controller/metal/strong_parameters.rb:336:in `to\_query’  
> actionpack-7.0.7/lib/action\_dispatch/http/url.rb:85:in `block in add_params' actionpack-7.0.7/lib/action_dispatch/http/url.rb:85:in `reject!’  
> actionpack-7.0.7/lib/action\_dispatch/http/url.rb:85:in `add_params' actionpack-7.0.7/lib/action_dispatch/http/url.rb:76:in `path\_for’  
> actionpack-7.0.7/lib/action\_dispatch/routing/route\_set.rb:333:in `block in <class:RouteSet>' actionpack-7.0.7/lib/action_dispatch/routing/route_set.rb:846:in `url\_for’  
> actionpack-7.0.7/lib/action\_dispatch/routing/route\_set.rb:271:in `call' actionpack-7.0.7/lib/action_dispatch/routing/route_set.rb:327:in `block in define\_url\_helper’

NoMethodError (undefined method `downcase' for #<ActionController::Parameters {" __proto__"=>{"expect"=>"100-continue"}, "constructor"=>{"prototype"=>{"expect"=>"100-continue"}}} permitted: false>) app/models/tag.rb:26:in `map’  
app/models/tag.rb:26:in `block in <class:Tag>' lib/topic_query.rb:1241:in `filter\_by\_tags’  
lib/topic\_query.rb:768:in `default_results' lib/topic_query.rb:538:in `latest\_results’  
lib/topic\_query.rb:281:in `list_latest' app/controllers/tags_controller.rb:159:in `public\_send’  
app/controllers/tags\_controller.rb:159:in `block (2 levels) in <class:TagsController>' app/controllers/tags_controller.rb:181:in `show’  
app/controllers/application\_controller.rb:421:in `block in with_resolved_locale' app/controllers/application_controller.rb:421:in `with\_resolved\_locale’  
lib/middleware/omniauth\_bypass\_middleware.rb:74:in `call' lib/content_security_policy/middleware.rb:12:in `call’  
lib/middleware/anonymous\_cache.rb:387:in `call' lib/middleware/gtm_script_nonce_injector.rb:10:in `call’  
config/initializers/100-quiet\_logger.rb:20:in `call' config/initializers/100-silence_logger.rb:29:in `call’  
lib/middleware/enforce\_hostname.rb:24:in `call' lib/middleware/request_tracker.rb:233:in `call’

Backtrace

app/models/tag.rb:26:in `map' app/models/tag.rb:26:in `block in class:Tag’  
activerecord (7.0.7) lib/active\_record/relation.rb:435:in `instance_exec' activerecord (7.0.7) lib/active_record/relation.rb:435:in `block in \_exec\_scope’  
activerecord (7.0.7) lib/active\_record/relation.rb:881:in `_scoping' activerecord (7.0.7) lib/active_record/relation.rb:435:in `\_exec\_scope’  
activerecord (7.0.7) lib/active\_record/scoping/named.rb:175:in `block in scope' lib/topic_query.rb:1241:in `filter\_by\_tags’  
lib/topic\_query.rb:768:in `default_results' lib/topic_query.rb:538:in `latest\_results’  
[/details]

> **Sidekiq is consuming too much memory (using: 504.11M)**
>
> Messaggio (4012 copie riportate)
> 
> Sidekiq sta consumando troppa memoria (utilizzo: 504.11M) per ‘[discuss.domain.com](http://discuss.domain.com)’, riavvio in corso
> 
> Backtrace
> 
> config/unicorn.conf.rb:164:in `check_sidekiq_heartbeat' config/unicorn.conf.rb:244:in `master\_sleep’  
> /var/www/discourse/vendor/bundle/ruby/3.2.0/gems/unicorn-6.1.0/lib/unicorn/http\_server.rb:295:in `join' /var/www/discourse/vendor/bundle/ruby/3.2.0/gems/unicorn-6.1.0/bin/unicorn:128:in `\<top (required)\>’  
> /var/www/discourse/vendor/bundle/ruby/3.2.0/bin/unicorn:25:in `load' /var/www/discourse/vendor/bundle/ruby/3.2.0/bin/unicorn:25:in `’

---

<div class="post-metadata">

### Author: ![pfaffman](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/pfaffman/32/120154_2.png) [@pfaffman](https://meta.discourse.org/u/pfaffman)
#### Post date: [8 Novembre 2023, 5:29am UTC](https://meta.discourse.org/t/errors-on-a-forum-i-volunteer-with/284654/2 "2023-11-08T05:29:07Z")

</div>

Sembra che il server debba essere aggiornato e alcune impostazioni nei file yml modificate. Non è possibile farlo da Discourse.

---

<div class="post-metadata">

### Author: ![sunjam](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/sunjam/32/175682_2.png) [@sunjam](https://meta.discourse.org/u/sunjam)
#### Post date: [22 Dicembre 2023, 7:07pm UTC](https://meta.discourse.org/t/errors-on-a-forum-i-volunteer-with/284654/4 "2023-12-22T19:07:16Z")

</div>

Sidekiq è stato aumentato a 1 GB di RAM e la coda email di Amazon è stata svuotata. Gli errori di log che vedo ora sono tutti Job exception: execution expired

Messaggio (532 copie segnalate)

Job exception: execution expired

Backtrace

/var/www/discourse/vendor/bundle/ruby/3.2.0/gems/net-smtp-0.4.0/lib/net/smtp.rb:631:in `initialize' /var/www/discourse/vendor/bundle/ruby/3.2.0/gems/net-smtp-0.4.0/lib/net/smtp.rb:631:in `open’  
/var/www/discourse/vendor/bundle/ruby/3.2.0/gems/net-smtp-0.4.0/lib/net/smtp.rb:631:in `tcp_socket' /var/www/discourse/vendor/bundle/ruby/3.2.0/gems/net-smtp-0.4.0/lib/net/smtp.rb:641:in `block in do\_start’  
/var/www/discourse/vendor/bundle/ruby/3.2.0/gems/timeout-0.4.1/lib/timeout.rb:186:in `block in timeout' /var/www/discourse/vendor/bundle/ruby/3.2.0/gems/timeout-0.4.1/lib/timeout.rb:193:in `timeout’  
/var/www/discourse/vendor/bundle/ruby/3.2.0/gems/net-smtp-0.4.0/lib/net/smtp.rb:640:in `do_start' /var/www/discourse/vendor/bundle/ruby/3.2.0/gems/net-smtp-0.4.0/lib/net/smtp.rb:610:in `start’  
/var/www/discourse/vendor/bundle/ruby/3.2.0/gems/mail-2.8.1/lib/mail/network/delivery\_methods/smtp.rb:109:in `start_smtp_session' /var/www/discourse/vendor/bundle/ruby/3.2.0/gems/mail-2.8.1/lib/mail/network/delivery_methods/smtp.rb:100:in `deliver!’
