@neil found the fix. Good sleuthing! ![]()
From the command line:
cd /var/discourse
./launcher enter app
rails c
Upload.update_all(secure: false)
This brings the site back up for me. @biyaniyash please give it a shot and let us know how it goes.
The explanation for this is that, on Discourse for Teams, https://meta.discourse.org/t/secure-media-uploads/meta/140017?u=tobiaseigen is enabled which requires S3. On the newly restored self-hosted site, secure media is disabled and uploads are stored locally on the server. But any existing uploads from the backup were already marked as secure, resulting in errors.