Errors when I changed my hostname


(Jared Needell) #1

So I went into app.yml to change my hostname.

Did a ./launcher bootstrap app thinking that’s what I needed to do to rebuild. Got an error so I did rebuild app instead same errors.

So I rebooted and tried again, no luck

Here’s a pastebin of my rebuild output

http://pastebin.com/4yNtdenq

Sorry if this is a repost just panicking that I didn’t lose my data.


(Jared Needell) #2

Can anyone help out with this?


Correct way to update docker?
(Sam Saffron) #3

Looks like a really old install, something is bad db wise.

PG::InvalidTextRepresentation: ERROR:  invalid input syntax for integer: ""
: UPDATE site_settings SET value = value::integer * 1440 WHERE name = 'default_email_digest_frequency' AND value IS NOT NULL/var/www/discourse/vendor/bundle/ruby/2.0.0/gems/rack-mini-profiler-0.9.9.2/lib/patches/db/pg.rb:90:in `exec'

to fix:

./launcher enter app
rails c
> SiteSetting.exec_sql("DELETE site_settings WHERE name = 'default_email_digest_frequency' ")

We should probably amend the migration to be more forgiving here.


(Jared Needell) #4

So I’m only maybe a 1 month or 2 behind.

I ran what you tried then did a rebuild app again. Still failed, here’s a paste bin.
http://pastebin.com/RLi7KBPZ

Do you think this has anything to do with the fact I did a “bootstrap” app instead of a “rebuild” app when I updated the app.yml file to an existing discourse?


(Jared Needell) #5

Looks like the email digest error never went away


(Sam Saffron) #6

Try changing that site setting then via admin interface


(Jared Needell) #7

Made that change via admin console and worked thanks!