es6 embedded Ruby (erb) controller not working?

plugins

(Joe Seyfried) #1

I haven’t found anything on this, so I’m afraid this simply will not work: in order to migrate an older plugin, I’d like to create a controller for a plugin (say plugin.js.es6). That works - but I need to create an embedded Ruby file - when I move to plugin.js.es6.erb, things go awry - the console tells me there is no controller defined. Does anyone have any insights if I’m doing something fundamentally wrong here?


(Sam Saffron) #2

Wait, why do you need erb here, its generally a very problematic practice (so problematic that we almost never use this in core)

Instead create hidden site settings if you need or use some other technique.

What exactly are you trying to do here?


(Joe Seyfried) #3

Hm… That’s for a preliminary emoji-plugin which provides a compatibility layer for my current forum software. All I do there is enumerate the smiley-image files in a given directory and store it in the controller…