ES6 header view update may break rendering


(Dan Porter) #1

Empty Home Page after deploying Discourse Docker
(Kane York) #2

Pinging @eviltrout !

Uncaught Error: Could not find module discourse/views/pagedown-preview vendor-079af679d7a4a569ab47fc53357d52d9.js:14
Uncaught TypeError: Cannot read property 'call' of undefined application-9f859ba2052cffeb0fd5519598d02939.js:2
Uncaught TypeError: Cannot read property 'create' of undefined vendor-079af679d7a4a569ab47fc53357d52d9.js:12

(Dan Chao) #3

I’m having this error as well


(Ilya Grigorik) #4

/sub … same issue. Just ran an upgrade, and site is coming up as a blank page. :frowning:


(Matthew David Wilkinson) #5

Having the same issue :frowning:


(Robin Ward) #6

Sorry I missed the bug but it should be fixed in the latest commit!

edit: It might still be broken. I’m confirming and on it.


(Robin Ward) #7

Confirmed fixed with this commit, sorry guys!


(Kane York) #8

@stealthii @bioball @igrigorik @Matthew_David_W - see above, it appears to be fixed


(Ilya Grigorik) #9

Looks like the web frontend for upgrades is broken due to same error. What’s the manual process?


(Robin Ward) #10

That’s odd, it did not break for me on my server when I had the error (it doesn’t use the same Javascript.) Are you trying the path /admin/docker?


(Ilya Grigorik) #11

Yep, seeing the same error on /admin/docker.


(Robin Ward) #12

Hmmm that is super weird! Do you have a really out of date docker_manager install? Did it look like this before it broke?

In terms of fixing it, bootstrapping again should fix it:

$ cd /var/docker
$ ./launcher stop app
$ ./launcher destroy app
$ ./launcher bootstrap app
$ ./launcher start app

Even though it says destroy it should keep your app data intact.


(Ilya Grigorik) #13

Thanks, that did the trick. Looks like I had an old version docker manager.


(Sam Saffron) #14

FYI, in future there is a little bit more efficient “rescue” sequence.

cd /var/docker
git pull 
./launcher rebuild app

(system) #15

This topic was automatically closed after 24 hours. New replies are no longer allowed.