Export CSV not working on Staff Action logs tab


(cpradio) #1

Only works if you are an admin though…


Show Emails - Staff Actions problem in the wings?
(Arpit Jalan) #2

This is not true. Can you please update your instance to the latest version and test again?


(Mittineague) #3

I tried at staging a few hours ago, but still nothing. Is this a scheduled thing that hasn’t run yet?


(Arpit Jalan) #4

Nope, you should be able to see Export button:


(Mittineague) #5

Yes I see the button.
It changes contrast on hover and a tooltip shows
"Export full staff action log in CSV format"

But nothing seems to happen on clicking it, neither immediately nor after a while.
Something not enabled because it’s staging perhaps @santouras ?


(cpradio) #6

Still doesn’t work. We can see the button (in all places), but never get a PM with the link unless I’m an admin…

You are talking about the Logs section right @techAPJ? Not the one on everyone’s Profile page (that one works).

Okay, so on my local dev environment, it works, but on our staging environment, it definitely doesn’t. Does the amount of data matter? Does it require sidekiq to be running?


(Arpit Jalan) #7

Yes, the sidekiq must be running. The export file is created in a background job.


(cpradio) #8

Okay, from what I can tell, it should be running… but since I don’t have physical access, I can’t actually verify it.

Normally, if sidekiq isn’t running you get a message at the version check… I should also note, we are on the latest beta release. We are not on master.

ping @santouras (adding santouras, as he does have physical access)


(Arpit Jalan) #9

I just tried to export “Staff Action” logs for meta, and I didn’t receive any PM for approx. ten minutes, so I marked it as bug and started looking into it… then suddenly I received the PM and the downloaded file was 13.4 MB.

It turns out that the background job took approx. ten minutes to run this process and create the CSV file. Is this may be the case for you? Can you try exporting entities other than “staff action” logs? (screened emails, ips)

EDIT: the background job took seven minutes to be exact.


(cpradio) #10

Here is the experience, I have with ALL of the export options under logs.

  1. I see the export button
  2. I click it
  3. I don’t get a modal window confirming the export…

Looking at the Developer Console, here is the error I have (just thought to look for one… now that I’ve had my caffeine fix)

GET http://staging-community.sitepoint.com/admin/export_csv/export_entity.json?entity=screened_email&_=1419864391504 404 (Not Found)_vendor-514d538a8a080bf81791da4c2da01aab.js:2964 X.cors.e.crossDomain.send_vendor-514d538a8a080bf81791da4c2da01aab.js:2964 Z.extend.ajax_application-9f069e2e71342b1326e78bd2ff0e625d.js:166 a_vendor-514d538a8a080bf81791da4c2da01aab.js:48556 __vendor-514d538a8a080bf81791da4c2da01aab.js:50184 h_application-9f069e2e71342b1326e78bd2ff0e625d.js:180 Discourse.Ajax.Em.Mixin.create.ajax_admin-5f37ddbbcd593e6606fc684943e823d4.js:5630 Discourse.ExportCsv.reopenClass.exportScreenedEmailList_admin-5f37ddbbcd593e6606fc684943e823d4.js:3544 s.default.Ember.ArrayController.extend.actions.exportScreenedEmailList_vendor-514d538a8a080bf81791da4c2da01aab.js:32384 o.create.send_vendor-514d538a8a080bf81791da4c2da01aab.js:22720 (anonymous function)_vendor-514d538a8a080bf81791da4c2da01aab.js:3152 s.run_vendor-514d538a8a080bf81791da4c2da01aab.js:20833 l_vendor-514d538a8a080bf81791da4c2da01aab.js:22718 b.registeredActions.(anonymous function).handler_vendor-514d538a8a080bf81791da4c2da01aab.js:39972 (anonymous function)_vendor-514d538a8a080bf81791da4c2da01aab.js:2963 Z.event.dispatch_vendor-514d538a8a080bf81791da4c2da01aab.js:2963 g.handle

@santouras, seems something is botched with our staging site.


Screened IPs Sort should also sort by Last Matched (or Created)
(Jeff Atwood) #11

It took about 5 solid minutes to export staff action logs here, so it definitely takes a while on that one.