# External nginx proxy and https false error

**URL:** https://meta.discourse.org/t/external-nginx-proxy-and-https-false-error/397128
**Category:** Self-hosting
**Tags:** nginx
**Created:** [February 26, 2026, 12:51pm UTC](https://meta.discourse.org/t/external-nginx-proxy-and-https-false-error/397128 "2026-02-26T12:51:23Z")
**Posts on this page:** 5
**Page:** 1

<div class="post-metadata">

### Author: ![Dataaja95](https://avatars.discourse-cdn.com/v4/letter/d/96bed5/32.png) [@Dataaja95](https://meta.discourse.org/u/Dataaja95)
#### Post date: [February 26, 2026, 12:51pm UTC](https://meta.discourse.org/t/external-nginx-proxy-and-https-false-error/397128/1 "2026-02-26T12:51:23Z")

</div>

hi

I am using an external nginx proxy in front of the discourse basic docker installation, everything else worked great except that mobile app users cannot log in and the api keys are not displayed in the admin control panel. In addition, the rails console gives the command  
request = ActionDispatch::Request.new({})  
request.ssl? the result is false so apparently the docker internal nginx thinks that http is used instead of https, I have configured app.y like this, is this the correct configuration nginx runs on the same machine as discourse not in docker.

Do you see any obvious errors or shortcomings in the app.yml configuration? External nginx handles certificates and SSL termination.

- “templates/web.template.yml”

- “templates/web.ratelimited.template.yml”

- “templates/web.ssl.template.yml”

#- “templates/web.letsencrypt.ssl.template.yml”

- “templates/web.socketed.template.yml”
- #expose:
- #- “80:80” # http
- #- “443:443” # https

env:

DISCOURSE\_FORCE\_HTTPS: true

DISCOURSE\_TRUSTED\_PROXIES: 127.0.0.1,172.17.0.1

---

<div class="post-metadata">

### Author: ![Dataaja95](https://avatars.discourse-cdn.com/v4/letter/d/96bed5/32.png) [@Dataaja95](https://meta.discourse.org/u/Dataaja95)
#### Post date: [February 26, 2026, 8:03pm UTC](https://meta.discourse.org/t/external-nginx-proxy-and-https-false-error/397128/2 "2026-02-26T20:03:04Z")

</div>

The solution to the problem was simpler than I thought, it was pure user error, so the server is fine.

---

<div class="post-metadata">

### Author: ![Jagster](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/jagster/32/192154_2.png) [@Jagster](https://meta.discourse.org/u/Jagster)
#### Post date: [February 26, 2026, 9:38pm UTC](https://meta.discourse.org/t/external-nginx-proxy-and-https-false-error/397128/3 "2026-02-26T21:38:41Z")

</div>

Would you like to tell what was the solution?

---

<div class="post-metadata">

### Author: ![Dataaja95](https://avatars.discourse-cdn.com/v4/letter/d/96bed5/32.png) [@Dataaja95](https://meta.discourse.org/u/Dataaja95)
#### Post date: [February 27, 2026, 7:13am UTC](https://meta.discourse.org/t/external-nginx-proxy-and-https-false-error/397128/4 "2026-02-27T07:13:18Z")

</div>

The user had accidentally downloaded the Discord mobile software and tried to log in to Discourse with it. I guided him to download the correct software, Discourse Hub, and he was able to log in to the forum. No adjustments were needed on the server side.

---

<div class="post-metadata">

### Author: ![system](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/system/32/443519_2.png) [@system](https://meta.discourse.org/u/system)
#### Post date: [March 29, 2026, 7:14am UTC](https://meta.discourse.org/t/external-nginx-proxy-and-https-false-error/397128/5 "2026-03-29T07:14:14Z")

</div>

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.
