Facebook and G+ don't show excerpt for private communities


(Spero Koulouras) #1

When sharing to Facebook or G+ the text from the current topic or post is not copied over on my forum as it is here on Meta. All I get is my site URL and description. Any ideas?

Continuing the discussion from Sharing to social networks:


(Jeff Atwood) #5

Sorry about the image link.

The answer is because your community is private:

Welcome to your online community for the Greater Good Science Center’s “The Science of Happiness”

It’s a place where teachers and students can find one another, connect with one another, and share what they know in specific areas of expertise.

Please Log In to continue. You will be asked to create an account if you have not already done so.

Facebook cannot “log in” to see the post.


(Spero Koulouras) #6

Hmm. Your answer makes sense, but on my test machine dev.sennseis.com I unchecked “login required” in the settings screen, saved the change, logged out, logged back in and tried it again with the same result.


(Kane York) #7

It’s always possible that Facebook has it cached - try changing the URL with login required off.


(Spero Koulouras) #8

changing the url? as in the name of the site or just the topic getting shared? From a brand new browser on a brand new machine I just logged in to the existing discourse install which has login-required off (but I logged in anyway) and tried a share of a completely different topic. Same result - the share did not include the text, just the site info.


(Kane York) #9

Er, whoops - phone typo. I tried to say: Change the URL that you’re entering at Facebook, it’s possible they have it cached.