Facebook/google and also twitter login error


#1

After a ./launcher cleanup, the problem is solved.
What is it the origin of this problem ?


(Matt Palmer) #2

Something was wrong.


#3

@mpalmer yes but i did not do anything :frowning: so i’m confused


#4

Anyone can help me to fix this bug on my server please ? i launched a ./launcher cleanup and i reboot the server but it persists


(David Taylor) #5

You said the problem was solved… Has it come back?


#6

Yes @David_Taylor :confused: The same problem in this topic Facebook login not working?


(David Taylor) #7

Have you followed the setup instructions? Configuring Facebook login for Discourse

Particularly this bit about having the correct protocol:


#8

yes @David_Taylor , i followed all the setup instruction, and i put the good path /auth/facebook/callback

I try again to connect and miracle, it’s work, i’m very confused !!

Edit: An other try, now it’s not work…
Edit 2: I try with an other navigator Microsoft Edge and it’s work…

Perhaps, a problem with the navigator ? I use google chrome and some of addons like Ghostery…


(Jeff Atwood) #9

Try in safe mode with all browser extensions disabled.


#10

we need to put : http://www.mywebsite.com and not http://mywebsite like that is mentioned in the tutorial how to
Microsoft Edge recognize the error, this is why it’s worked in this navigator


(Christoph) #11

Nobody knows the correct domain except for yourself. It depends on your DNS setup.


#12

facebook/google login only work on webbrowser ? beaceause it’s not working on mobile browser
Anyone have a solution?


#13

http://www.mywebsite.com and not http://mywebsite

I put the two link in facebook/google config and now, it’s work !

@tophee it’s not a problem with my dns config