# "Failed listening on port 6379 (TCP)" stops installation

**URL:** <https://meta.discourse.org/t/failed-listening-on-port-6379-tcp-stops-installation/386891>\
**Category:** Self-hosting\
**Tags:** hosting\
**Created:** [October 28, 2025, 4:08am UTC](https://meta.discourse.org/t/failed-listening-on-port-6379-tcp-stops-installation/386891 "2025-10-28T04:08:30Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![b11](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/b11/32/527089_2.png) [@b11](https://meta.discourse.org/u/b11)\
**Post date:** [October 28, 2025, 4:08am UTC](https://meta.discourse.org/t/failed-listening-on-port-6379-tcp-stops-installation/386891/1 "2025-10-28T04:08:30Z")

</div>

Right after Redis starts in the installation, it outputs this: `Warning: Could not create server TCP listening socket *:6379: bind: Address already in use` then `Failed listening on port 6379 (TCP), aborting.` I have no clue why this happens. I’ve switched the ports in the Redis configuration file and this problem still occurs. Other articles have not helped.

Raw log: [y23qwgerghfds - Pastebin.com](https://pastebin.com/687JV5EP)

Any help is appreciated!

---

<div class="post-metadata">

**Author:** ![pangbo](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/pangbo/32/538562_2.png) [@pangbo](https://meta.discourse.org/u/pangbo)\
**Post date:** [October 28, 2025, 7:00am UTC](https://meta.discourse.org/t/failed-listening-on-port-6379-tcp-stops-installation/386891/2 "2025-10-28T07:00:43Z")

</div>

You can simply ignore this line, as the end of your raw log shows the rebuilding succeeded.

---

<div class="post-metadata">

**Author:** ![b11](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/b11/32/527089_2.png) [@b11](https://meta.discourse.org/u/b11)\
**Post date:** [October 28, 2025, 11:41pm UTC](https://meta.discourse.org/t/failed-listening-on-port-6379-tcp-stops-installation/386891/3 "2025-10-28T23:41:44Z")

</div>

Hi! Thank you, and this did help very much. However, I am also encountering this problem: when running `./discourse-setup` the site returns this:

 ![image](https://global.discourse-cdn.com/meta/original/4X/7/e/a/7ea56b110b7a6dc2a04fa3becf0b366f06a82700.png)  
I do have the A address properly setup in my DNS records. Ports 443 and 80 are not in use and available when I run the setup command.

When running `curl https://mywebsite.app`-  
`curl: (7) Failed to connect to mywebsite.app port 443 after 33 ms: Couldn’t connect to server`

After killing what was using port 443 (it was being used during setup), and running `curl` again, it returned the same thing (the only difference being the times- 33ms → 2ms before outputting)

Raw log - [abc - Pastebin.com](https://pastebin.com/cLNxRAjC)

_(I’m not sure if it’s supposed to output `Discourse installed` or something along those lines, however it does not do that)  
Running Ubuntu 24.04.3 LTS, Digital Ocean droplet_

---

<div class="post-metadata">

**Author:** ![b11](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/b11/32/527089_2.png) [@b11](https://meta.discourse.org/u/b11)\
**Post date:** [October 29, 2025, 2:27am UTC](https://meta.discourse.org/t/failed-listening-on-port-6379-tcp-stops-installation/386891/4 "2025-10-29T02:27:14Z")

</div>

Regarding above, the wrong A address was put in (private IP) instead of public IPV4. Oops! Thank you for helping!

---

<div class="post-metadata">

**Author:** ![system](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/system/32/443519_2.png) [@system](https://meta.discourse.org/u/system)\
**Post date:** [November 28, 2025, 2:27am UTC](https://meta.discourse.org/t/failed-listening-on-port-6379-tcp-stops-installation/386891/5 "2025-11-28T02:27:26Z")

</div>

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.
