# Failed new install

**URL:** https://meta.discourse.org/t/failed-new-install/357790
**Category:** Self-hosting
**Created:** [March 18, 2025, 3:39pm UTC](https://meta.discourse.org/t/failed-new-install/357790 "2025-03-18T15:39:06Z")
**Posts on this page:** 9
**Page:** 1

<div class="post-metadata">

### Author: ![Heliosurge](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/heliosurge/32/571810_2.png) [@Heliosurge](https://meta.discourse.org/u/Heliosurge)
#### Post date: [March 18, 2025, 3:39pm UTC](https://meta.discourse.org/t/failed-new-install/357790/1 "2025-03-18T15:39:06Z")

</div>

VPS 4 core 4g 200g. Ubuntu 24 lts  
Domain reg: IONOS

```plaintext
[2025-03-18T14:54:01.632117 #1] INFO -- : > cd /var/www/discourse && su discourse -c 'bundle exec rake assets:precompile:build'
Node.js heap_size_limit (2005.75) is less than 2048MB. Setting --max-old-space-size=2048 and CHEAP_SOURCE_MAPS=1
...[ConfigLoader]
...[Babel: discourse-widget-hbs > applyPatches]
...[Babel: @embroider/macros > applyPatches]
...[Babel: ember-tracked-storage-polyfill > applyPatches]
...[Babel: pretty-text > applyPatches]
...[Babel: @ember/legacy-built-in-components > applyPatches]
...[Babel: ember-source > applyPatches]
[BABEL] Note: The code generator has deoptimised the styling of /var/www/discourse/app/assets/javascripts/discourse/ember/ember-template-compiler.js as it exceeds the max of 500KB.
[BABEL] Note: The code generator has deoptimised the styling of /var/www/discourse/app/assets/javascripts/discourse/ember/ember.js as it exceeds the max of 500KB.
...[Babel: @glimmer/component > applyPatches]
...[Babel: @ember/test-waiters > applyPatches]
...[Babel: dialog-holder > applyPatches]
...[Babel: ember-buffered-proxy > applyPatches]
...[Babel: float-kit > applyPatches]
...[Babel: select-kit > applyPatches]
...[@embroider/compat/app]
...[@embroider/webpack]
...[@embroider/webpack]
...[@embroider/webpack]
...[@embroider/webpack]
...[@embroider/webpack]
...[@embroider/webpack]
2025-03-18 14:55:50.590 UTC [51] LOG: checkpoint starting: time
2025-03-18 14:55:55.247 UTC [51] LOG: checkpoint complete: wrote 48 buffers (0.0%); 0 WAL file(s) added, 0 removed, 0 recycled; write=4.612 s, sync=0.016 s, total=4.657 s; sync files=38, longest=0.004 s, average=0.001 s; distance=202 kB, estimate=202 kB
...[@embroider/webpack]
109:M 18 Mar 2025 14:55:57.065 * 100 changes in 300 seconds. Saving...
109:M 18 Mar 2025 14:55:57.067 * Background saving started by pid 758
758:C 18 Mar 2025 14:55:57.087 * DB saved on disk
758:C 18 Mar 2025 14:55:57.088 * Fork CoW for RDB: current 0 MB, peak 0 MB, average 0 MB
109:M 18 Mar 2025 14:55:57.168 * Background saving terminated with success
...[@embroider/webpack]
...[@embroider/webpack]
...[@embroider/webpack]
...[@embroider/webpack]
...[SourceMapConcat]
...[Babel: admin > applyPatches]
...[Babel: admin > applyPatches]
...[Babel: admin > applyPatches]
...[SourceMapConcat]
...[TerserWriter]
...[TerserWriter]
...[Babel: discourse > applyPatches]
...[SourceMapConcat]
...[Babel: discourse > applyPatches]
...[SourceMapConcat]
...[Babel: discourse > applyPatches]
...[TerserWriter]
...[Babel: discourse-plugins > applyPatches]
...[Babel: discourse-plugins > applyPatches]
...[SourceMapConcat]
...[Babel: discourse-plugins > applyPatches]
...[SourceMapConcat]
...[Babel: discourse-plugins > applyPatches]
...[SourceMapConcat]
...[Babel: discourse-plugins > applyPatches]
...[SourceMapConcat]
...[Babel: discourse-plugins > applyPatches]
...[SourceMapConcat]
...[Babel: discourse-plugins > applyPatches]
...[SourceMapConcat]
...[Babel: discourse-plugins > applyPatches]
...[SourceMapConcat]
...[Babel: discourse-plugins > applyPatches]
...[SourceMapConcat]
...[Babel: discourse-plugins > applyPatches]
...[SourceMapConcat]
...[Babel: discourse-plugins > applyPatches]
...[SourceMapConcat]
...[TerserWriter]
I, [2025-03-18T14:58:35.058799 #1] INFO -- : Building
Environment: production
The setting 'staticAddonTrees' will default to true in the next version of Embroider and can't be turned off. To prepare for this you should set 'staticAddonTrees: true' in your Embroider config.
The setting 'staticAddonTestSupportTrees' will default to true in the next version of Embroider and can't be turned off. To prepare for this you should set 'staticAddonTestSupportTrees: true' in your Embroider config.
building...
undefined
 ERR_PNPM_RECURSIVE_EXEC_FIRST_FAIL Command was killed with SIGKILL (Forced termination): ember build -prod

I, [2025-03-18T14:58:35.082462 #1] INFO -- : Terminating async processes
I, [2025-03-18T14:58:35.082680 #1] INFO -- : Sending INT to HOME=/var/lib/postgresql USER=postgres exec chpst -u postgres:postgres:ssl-cert -U postgres:postgres:ssl-cert /usr/lib/postgresql/15/bin/postmaster -D /etc/postgresql/15/main pid: 42
I, [2025-03-18T14:58:35.082935 #1] INFO -- : Sending TERM to exec chpst -u redis -U redis /usr/bin/redis-server /etc/redis/redis.conf pid: 109
2025-03-18 14:58:35.083 UTC [42] LOG: received fast shutdown request
109:signal-handler (1742309915) Received SIGTERM scheduling shutdown...
2025-03-18 14:58:35.092 UTC [42] LOG: aborting any active transactions
2025-03-18 14:58:35.101 UTC [42] LOG: background worker "logical replication launcher" (PID 56) exited with exit code 1
2025-03-18 14:58:35.108 UTC [51] LOG: shutting down
2025-03-18 14:58:35.113 UTC [51] LOG: checkpoint starting: shutdown immediate
2025-03-18 14:58:35.137 UTC [51] LOG: checkpoint complete: wrote 0 buffers (0.0%); 0 WAL file(s) added, 0 removed, 0 recycled; write=0.009 s, sync=0.001 s, total=0.029 s; sync files=0, longest=0.000 s, average=0.000 s; distance=0 kB, estimate=182 kB
109:M 18 Mar 2025 14:58:35.150 # User requested shutdown...
109:M 18 Mar 2025 14:58:35.151 * Saving the final RDB snapshot before exiting.
109:M 18 Mar 2025 14:58:35.166 * DB saved on disk
109:M 18 Mar 2025 14:58:35.167 # Redis is now ready to exit, bye bye...
2025-03-18 14:58:35.174 UTC [42] LOG: database system is shut down

FAILED
--------------------
Pups::ExecError: cd /var/www/discourse && su discourse -c 'bundle exec rake assets:precompile:build' failed with return #<Process::Status: pid 696 exit 1>
Location of failure: /usr/local/lib/ruby/gems/3.3.0/gems/pups-1.2.1/lib/pups/exec_command.rb:132:in `spawn'
exec failed with the params {"cd"=>"$home", "tag"=>"build", "hook"=>"assets_precompile_build", "cmd"=>["su discourse -c 'bundle exec rake assets:precompile:build'"]}
bootstrap failed with exit code 1
**FAILED TO BOOTSTRAP** please scroll up and look for earlier error messages, there may be more than one.
./discourse-doctor may help diagnose the problem.

```

Followed [standard install](https://meta.discourse.org/t/142537?silent=true). Set domain DNS a name record “community” with IP address.

IONOS doesn’t have free SSL. So populated discourse-setup let’s encrypt email entry.

Need help figuring this out.

---

<div class="post-metadata">

### Author: ![Ed\_S](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/ed_s/32/134015_2.png) [@Ed\_S](https://meta.discourse.org/u/Ed_S)
#### Post date: [March 18, 2025, 9:18pm UTC](https://meta.discourse.org/t/failed-new-install/357790/3 "2025-03-18T21:18:28Z")

</div>

Could it be memory? Do you have swap? Can you add 4G of swap?

---

<div class="post-metadata">

### Author: ![Heliosurge](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/heliosurge/32/571810_2.png) [@Heliosurge](https://meta.discourse.org/u/Heliosurge)
#### Post date: [March 18, 2025, 10:59pm UTC](https://meta.discourse.org/t/failed-new-install/357790/4 "2025-03-18T22:59:42Z")

</div>

That is possible. No swap setup.

~~Could you share the command to add a 4g swap. Been awhile since have played around with that.~~

Found this topic working on it. Thanks

> [@Create a swapfile for your Linux server](https://meta.discourse.org/t/create-a-swapfile-for-your-linux-server/13880):
>
> bulb For servers with \<= 4GB of RAM, running ./discourse-setup will prompt for and automatically create a 2GB swapfile. Most cloud virtual machine providers do not set up swapfiles as part of their server provisioning. In particular, upgrading Discourse produces a lot of memory pressure. With a swap file, rather than randomly terminating processes with an out of memory error, things will slow down instead. Having a swap file is a cheap insurance policy that protects you from many other lo…

---

<div class="post-metadata">

### Author: ![pfaffman](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/pfaffman/32/120154_2.png) [@pfaffman](https://meta.discourse.org/u/pfaffman)
#### Post date: [March 18, 2025, 11:36pm UTC](https://meta.discourse.org/t/failed-new-install/357790/5 "2025-03-18T23:36:26Z")

</div>

> [@Heliosurge](#):
>
> `SIGKILL (Forced termination`

I think this means that it took too long.

I would try adding swap and/or ram.

I could try reading the other posts before I say the same thing that everyone else did.

---

<div class="post-metadata">

### Author: ![Heliosurge](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/heliosurge/32/571810_2.png) [@Heliosurge](https://meta.discourse.org/u/Heliosurge)
#### Post date: [March 19, 2025, 12:11am UTC](https://meta.discourse.org/t/failed-new-install/357790/6 "2025-03-19T00:11:29Z")

</div>

Added swap. Believe it built correctly. Now I am having

 ![This image shows an error page stating "ERR_TOO_MANY_REDIRECTS" for the website "nunity.nsfIRE_hub.ca" and advising to try deleting cookies, with a "Reload" button. (Captioned by AI)](https://global.discourse-cdn.com/meta/original/4X/4/0/e/40ea1ad21e911c04bc1bb364dee03f71281a9bab.png)

I disabled the other DNS a record IONOS has.

Site address

> **[NSFirehub](https://community.nsfirehub.ca)**
>
> Community for Emergency Responders

It does look like I need to look into SMTP name maybe. Will post in the topic for Lark mail.

With using discourse-setup command. Do I need to do anything with the app yml to use Let’s Encrypt? During setup added let’s encrypt email for messages.

---

<div class="post-metadata">

### Author: ![pequiste](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/pequiste/32/490888_2.png) [@pequiste](https://meta.discourse.org/u/pequiste)
#### Post date: [March 19, 2025, 5:28am UTC](https://meta.discourse.org/t/failed-new-install/357790/8 "2025-03-19T05:28:12Z")

</div>

> Do I need to do anything with the app yml to use Let’s Encrypt?

You need to uncomment the letsencrypt bits in the app.yaml. It’s written in the file which lines you need to uncomment.

> It does look like I need to look into SMTP name maybe.

Run `./discourse-doctor`, it will try to find common problems and offer to send you a test e-mail.

---

<div class="post-metadata">

### Author: ![Heliosurge](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/heliosurge/32/571810_2.png) [@Heliosurge](https://meta.discourse.org/u/Heliosurge)
#### Post date: [March 19, 2025, 2:14pm UTC](https://meta.discourse.org/t/failed-new-install/357790/9 "2025-03-19T14:14:09Z")

</div>

Yeahran that seems that the domain is not properly connecting to server & maybe an issue on server?

```plaintext

Found containers/app.yml

==================== YML SETTINGS ====================
DISCOURSE_HOSTNAME=community.NSFirehub.ca
SMTP_ADDRESS=smtp.larksuite.com
DEVELOPER_EMAILS=redacted
SMTP_PASSWORD=redacted
SMTP_PORT=587
SMTP_USER_NAME=redacted
LETSENCRYPT_ACCOUNT_EMAIL=redacted

==================== DOCKER INFO ====================
DOCKER VERSION: Docker version 26.1.3, build 26.1.3-0ubuntu1~24.04.1

DOCKER PROCESSES (docker ps -a)

CONTAINER ID IMAGE COMMAND CREATED STATUS PORTS NAMES
186bfb732aa9 local_discourse/app "/sbin/boot" 2 minutes ago Up 2 minutes 0.0.0.0:80->80/tcp, :::80->80/tcp, 0.0.0.0:443->443/tcp, :::443->443/tcp app

186bfb732aa9 local_discourse/app "/sbin/boot" 2 minutes ago Up 2 minutes 0.0.0.0:80->80/tcp, :::80->80/tcp, 0.0.0.0:443->443/tcp, :::443->443/tcp app

Discourse container app is running

==================== PLUGINS ====================
          - git clone https://github.com/discourse/docker_manager.git

No non-official plugins detected.

See https://github.com/discourse/discourse/blob/main/lib/plugin/metadata.rb for the official list.

========================================
Discourse version at community.NSFirehub.ca: NOT FOUND
Discourse version at localhost: NOT FOUND

==================== MEMORY INFORMATION ====================
RAM (MB): 4105

               total used free shared buff/cache available
Mem: 3915 1857 553 54 1849 2057
Swap: 4095 86 4009

==================== DISK SPACE CHECK ====================
---------- OS Disk Space ----------
Filesystem Size Used Avail Use% Mounted on
/dev/sda1 193G 14G 180G 7% /

==================== DISK INFORMATION ====================
Disk /dev/sda: 200 GiB, 214748364800 bytes, 419430400 sectors
Disk model: QEMU HARDDISK
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 2CC9EFA8-F404-47D6-804F-06B18D2960CC

Device Start End Sectors Size Type
/dev/sda1 2099200 419430366 417331167 199G Linux filesystem
/dev/sda14 2048 10239 8192 4M BIOS boot
/dev/sda15 10240 227327 217088 106M EFI System
/dev/sda16 227328 2097152 1869825 913M Linux extended boot

Partition table entries are not in disk order.

==================== END DISK INFORMATION ====================

```

The Let’s Encrypt lines were uncommented by discourse-setup(verified)

---

<div class="post-metadata">

### Author: ![Heliosurge](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/heliosurge/32/571810_2.png) [@Heliosurge](https://meta.discourse.org/u/Heliosurge)
#### Post date: [March 19, 2025, 2:58pm UTC](https://meta.discourse.org/t/failed-new-install/357790/10 "2025-03-19T14:58:42Z")

</div>

![The image displays a pop-up message on a website congratulating the user for installing Discord and prompting to register a new account. (Captioned by AI)](https://global.discourse-cdn.com/meta/original/4X/a/8/c/a8c24c1595bf6bdf8cd171ffb52fbef06f670269.png)

Success. The issue was in the domain name. I had “community.NSFirehub.ca” after removing the caps it connected.

Thank you everyone for your help!

So in conclusion 2 issues

- Swapfile as mentioned by @Ed_S & @pfaffman
- and no caps in domain name.

I would recommend adding the instructions for creating swap file and info about no caps in domain name setup for discourse-setup/app yml. In the [official install](https://meta.discourse.org/t/142537?silent=true) github

---

<div class="post-metadata">

### Author: ![system](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/system/32/443519_2.png) [@system](https://meta.discourse.org/u/system)
#### Post date: [April 18, 2025, 2:58pm UTC](https://meta.discourse.org/t/failed-new-install/357790/11 "2025-04-18T14:58:47Z")

</div>

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.
