Failed to bootstrap due to RubyGems "no address associated with hostname"


(bootstraponline) #1

I’m helping to maintain a discourse site for appium (discuss.appium.io). Usually sudo ./launcher rebuild app fixes any problems however now the bootstrap is failing.

It’s hosted on digitalocean and from the logs it appears to be a DNS resolution problem. Is that accurate?

I checked /etc/resolv.conf and it’s using google DNS. The following command is failing:

$ wget https://bb-m.rubygems.org/quick/Marshal.4.8/actionpack-4.1.8.gemspec.rz
--2014-12-01 17:25:21--  https://bb-m.rubygems.org/quick/Marshal.4.8/actionpack-4.1.8.gemspec.rz
Resolving bb-m.rubygems.org (bb-m.rubygems.org)... failed: No address associated with hostname.
wget: unable to resolve host address ‘bb-m.rubygems.org’

It looks like this is a known failure with rubygems.org.


(bootstraponline) #2

The solution was to wait until rubygems/github stopped having network problems. Then sudo ./launcher rebuild app worked.


(Anton) #3

I seems as I’m having a similar issue right now.

What should I check exactly to know if the rubygems/github is having network problems or not - what did you mean exactly by that?


(Sam Saffron) #4

Rubygems outage out of our control

Follow @rubygems_status for updates.


(Jeff Atwood) #5

It seems fine now?

http://rubygems.org


(Anton) #6

Hm not yet in Ukraine.

P.S. For the time being I just restored from the recent snapshot - DigitalOcean rules :smile:


(jark) #7

still didn’t work. I edit the /etc/hosts with 54.186.104.15 rubygems.org, and the same.

it works!


(Sam Saffron) #8