# Fehler beim Bootstrap: Fehler beim Empfang von Netzwerkinformationen

**URL:** https://meta.discourse.org/t/failed-to-bootstrap-failure-with-receiving-network-data/61951
**Category:** Self-hosting
**Created:** [2. Mai 2017 um 11:21 UTC](https://meta.discourse.org/t/failed-to-bootstrap-failure-with-receiving-network-data/61951 "2017-05-02T11:21:26Z")
**Posts on this page:** 13
**Page:** 1

<div class="post-metadata">

### Author: ![craisp](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/craisp/32/119998_2.png) [@craisp](https://meta.discourse.org/u/craisp)
#### Post date: [2. Mai 2017 um 11:21 UTC](https://meta.discourse.org/t/failed-to-bootstrap-failure-with-receiving-network-data/61951/1 "2017-05-02T11:21:26Z")

</div>

Edit: The error changed, see 2nd post.

I tried rebuilding my app today.

```
FAILED
--------------------
Pups::ExecError: cd /var/www/discourse && git pull failed with return #<Process::Status: pid 189 exit 1>
Location of failure: /pups/lib/pups/exec_command.rb:108:in `spawn'
exec failed with the params {"cd"=>"$home", "hook"=>"code", "cmd"=>["git reset --hard", "git clean -f", "git remote set-branches --add origin master", "git pull", "git fetch origin $version", "git checkout $version", "mkdir -p tmp/pids", "mkdir -p tmp/sockets", "touch tmp/.gitkeep", "mkdir -p /shared/log/rails", "bash -c \"touch -a /shared/log/rails/{production,production_errors,unicorn.stdout,unicorn.stderr}.log\"", "bash -c \"ln -s /shared/log/rails/{production,production_errors,unicorn.stdout,unicorn.stderr}.log $home/log\"", "bash -c \"mkdir -p /shared/{uploads,backups}\"", "bash -c \"ln -s /shared/{uploads,backups} $home/public\"", "chown -R discourse:www-data /shared/log/rails /shared/uploads /shared/backups"]}
5eb4b2121e0bf2175cbf9ad39f9fb36bffa72011858ff54d6405c009bc0b0068
**FAILED TO BOOTSTRAP** please scroll up and look for earlier error messages, there may be more than one

```

Error is here:

```
INFO -- : > cd /var/www/discourse && git pull
fatal: unable to access 'https://github.com/discourse/discourse.git/': GnuTLS recv error (-54): Error in the pull function.

```

The bigger picture:  
This morning there was an issue with the Encryption of the site. Chrome reported: `NET::ERR_CERT_AUTHORITY_INVALID`  
That’s why I tried a rebuild. At the first attempt I had an `Failed To Bootstrap`-Error related to the `acme.sh`-Script

```
discourse Pups::ExecError: cd /root/acme.sh && LE_WORKING_DIR="${LETSENCRYPT_DIR}" ./acme.sh --upgrade --auto-upgrade failed with return #<Process::Status: pid 18927 exit 1>

```

I tried to this Debugging guide from [Set up HTTPS support with Let's Encrypt](https://meta.discourse.org/t/setting-up-lets-encrypt/40709)

> [@Set up HTTPS support with Let's Encrypt](https://meta.discourse.org/t/set-up-https-support-with-lets-encrypt/40709/1):
>
> Debugging
> 
> Check logs for cert related errors
> 
> ./launcher logs \<container name\>
> 
> Then look for any errors mentioning letsencrypt or SSL.
> 
> Did the cert files get written OK?
> 
> ls -l /var/discourse/shared/standalone/ssl on the host server
> 
> You should have a certificate .cer and key .key file for your domain, and they should have ~3k filesize.
> 
> -rw-r–r-- 1 root root 424 May 18 03:22 dhparams.pem  
> -rw-r–r-- 1 root root 3823 May 18 04:24 discourse.example.com.cer  
> -rw-r–r-- 1 root root 3243 May 18 04:24 discourse.example.com.key
> 
> Manually reissue the cert
> 
> ./launcher enter app  
> sv stop nginx  
> /usr/sbin/nginx -c /etc/nginx/letsencrypt.conf  
> LE\_WORKING\_DIR=/shared/letsencrypt DEBUG=1 /shared/letsencrypt/acme.sh --issue -d [example.com](http://example.com) -k 4096 -w /var/www/discourse/public  
> LE\_WORKING\_DIR=/shared/letsencrypt /shared/letsencrypt/acme.sh --installcert -d [example.com](http://example.com) --fullchainpath /shared/ssl/example.com.cer --keypath /shared/ssl/example.com.key --reloadcmd “sv reload nginx”  
> /usr/sbin/nginx -c /etc/nginx/letsencrypt.conf -s stop
> 
> Delete the old cert files and try rebuilding again
> 
> rm -rf /var/discourse/shared/standalone/ssl  
> rm -rf /var/discourse/shared/standalone/letsencrypt  
> ./launcher rebuild app

I got no error there.

Any ideas?

---

<div class="post-metadata">

### Author: ![craisp](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/craisp/32/119998_2.png) [@craisp](https://meta.discourse.org/u/craisp)
#### Post date: [2. Mai 2017 um 11:46 UTC](https://meta.discourse.org/t/failed-to-bootstrap-failure-with-receiving-network-data/61951/2 "2017-05-02T11:46:47Z")

</div>

Ok, I tried another rebuild and now it’s again the `acme.sh`-Error:

```
FAILED
--------------------
Pups::ExecError: cd /root/acme.sh && LE_WORKING_DIR="${LETSENCRYPT_DIR}" ./acme.sh --upgrade --auto-upgrade failed with return #<Process::Status: pid 18791 exit 1>
Location of failure: /pups/lib/pups/exec_command.rb:108:in `spawn'
exec failed with the params {"cmd"=>["cd /root && git clone https://github.com/Neilpang/acme.sh.git && cd /root/acme.sh && git reset --hard c4c5ecd03de497fd4c3079cbac9d3c56edaffc89", "touch /var/spool/cron/crontabs/root", "install -d -m 0755 -g root -o root $LETSENCRYPT_DIR", "cd /root/acme.sh && LE_WORKING_DIR=\"${LETSENCRYPT_DIR}\" ./acme.sh --install --log \"${LETSENCRYPT_DIR}/acme.sh.log\"", "cd /root/acme.sh && LE_WORKING_DIR=\"${LETSENCRYPT_DIR}\" ./acme.sh --upgrade --auto-upgrade"]}
285cbf01ab9ff0047b3d235ccd31697a47cf82e33fb8842badfb27b05a34b611
**FAILED TO BOOTSTRAP** please scroll up and look for earlier error messages, there may be more than one

```

Error is produced by this command:

```
INFO -- : > cd /root/acme.sh && LE_WORKING_DIR="${LETSENCRYPT_DIR}" ./acme.sh --upgrade --auto-upgrade
* 10 changes in 300 seconds. Saving...
* Background saving started by pid 18825
* DB saved on disk
* RDB: 0 MB of memory used by copy-on-write
* Background saving terminated with success
Please refer to https://curl.haxx.se/libcurl/c/libcurl-errors.html for error code: 56
Download error.
Upgrade failed!

```

Error Code 56 refers to [https://curl.haxx.se/libcurl/c/libcurl-errors.html:](https://curl.haxx.se/libcurl/c/libcurl-errors.html:)

```
CURLE_RECV_ERROR (56)
Failure with receiving network data.

```

---

<div class="post-metadata">

### Author: ![pfaffman](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/pfaffman/32/120154_2.png) [@pfaffman](https://meta.discourse.org/u/pfaffman)
#### Post date: [2. Mai 2017 um 13:02 UTC](https://meta.discourse.org/t/failed-to-bootstrap-failure-with-receiving-network-data/61951/3 "2017-05-02T13:02:54Z")

</div>

That sounds like network problems.

---

<div class="post-metadata">

### Author: ![craisp](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/craisp/32/119998_2.png) [@craisp](https://meta.discourse.org/u/craisp)
#### Post date: [2. Mai 2017 um 13:08 UTC](https://meta.discourse.org/t/failed-to-bootstrap-failure-with-receiving-network-data/61951/4 "2017-05-02T13:08:01Z")

</div>

sure 🙂

I’m running my app on a Linode server. I followed the 30 min docker setup and currently have no idea where to dive in tackling network problems. Do you have some keywords where to start?

---

<div class="post-metadata">

### Author: ![Falco](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/falco/32/179432_2.png) [@Falco](https://meta.discourse.org/u/Falco)
#### Post date: [2. Mai 2017 um 14:33 UTC](https://meta.discourse.org/t/failed-to-bootstrap-failure-with-receiving-network-data/61951/5 "2017-05-02T14:33:02Z")

</div>

I recommend using Ubuntu as the server distro image, it’s easier.

---

<div class="post-metadata">

### Author: ![craisp](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/craisp/32/119998_2.png) [@craisp](https://meta.discourse.org/u/craisp)
#### Post date: [2. Mai 2017 um 14:57 UTC](https://meta.discourse.org/t/failed-to-bootstrap-failure-with-receiving-network-data/61951/6 "2017-05-02T14:57:40Z")

</div>

I use an Ubuntu 16.04 LTS x64 image, kernel 4.9.15

---

<div class="post-metadata">

### Author: ![pfaffman](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/pfaffman/32/120154_2.png) [@pfaffman](https://meta.discourse.org/u/pfaffman)
#### Post date: [2. Mai 2017 um 14:59 UTC](https://meta.discourse.org/t/failed-to-bootstrap-failure-with-receiving-network-data/61951/7 "2017-05-02T14:59:57Z")

</div>

> [@craisp](#):
>
> Do you have some keywords where to start?

Not really. Linode should work. It could be some temporary DNS problem.

You can see if you can do this from the command line:

```
git clone https://github.com/Neilpang/acme.sh.git

```

If it fails, then you know that’s the problem, and if it does, there’s not much you can do but whine to Linode and/or github.

---

<div class="post-metadata">

### Author: ![craisp](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/craisp/32/119998_2.png) [@craisp](https://meta.discourse.org/u/craisp)
#### Post date: [2. Mai 2017 um 15:23 UTC](https://meta.discourse.org/t/failed-to-bootstrap-failure-with-receiving-network-data/61951/8 "2017-05-02T15:23:22Z")

</div>

Allright, thanks for your answer.

The manual `git clone` command works fine. The failure comes from different git pull commands during `./launcher rebuild app`.

I opened a linode-Ticket.

---

<div class="post-metadata">

### Author: ![pfaffman](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/pfaffman/32/120154_2.png) [@pfaffman](https://meta.discourse.org/u/pfaffman)
#### Post date: [2. Mai 2017 um 15:33 UTC](https://meta.discourse.org/t/failed-to-bootstrap-failure-with-receiving-network-data/61951/9 "2017-05-02T15:33:24Z")

</div>

Do you have any non official plug-ins installed?

---

<div class="post-metadata">

### Author: ![craisp](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/craisp/32/119998_2.png) [@craisp](https://meta.discourse.org/u/craisp)
#### Post date: [2. Mai 2017 um 15:36 UTC](https://meta.discourse.org/t/failed-to-bootstrap-failure-with-receiving-network-data/61951/10 "2017-05-02T15:36:38Z")

</div>

yes, there’s one.  
but last trial of `./launcher rebuild app` it failed already during

```
cd /var/www/discourse && git pull
fatal: unable to access 'https://github.com/discourse/discourse.git/': GnuTLS recv error (-54): Error in the pull function.

```

Is there anything plugin-related happening before that?  
Anyway: I’ll try rebuilding without that plugin.

---

<div class="post-metadata">

### Author: ![DeanMarkTaylor](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/deanmarktaylor/32/102462_2.png) [@DeanMarkTaylor](https://meta.discourse.org/u/DeanMarkTaylor)
#### Post date: [2. Mai 2017 um 16:12 UTC](https://meta.discourse.org/t/failed-to-bootstrap-failure-with-receiving-network-data/61951/11 "2017-05-02T16:12:27Z")

</div>

> [@craisp](#):
>
> GnuTLS recv error (-54): Error in the pull function.

Sounds like you have a connectivity issue inside the docker instance (yeah I know obvious)…

In CURL the error “56” is:

```plaintext
CURLE_RECV_ERROR (56)
Failure with receiving network data.

```

It also looks like this relates to TLS / certificates - this can **also** be to do with several things:

- Incorrect time / clock on your machine
- Certificate installation issues
- Check for OS updates (these might include certificates)
- Check for docker updates
- Actual connectivity issues

To get more information I would probably check the above things…

… and then if still at a loss modify the `templates/web.template.yml` temporarily on that specific `git pull` line from:

```plaintext
        - git remote set-branches --add origin master
        - git pull
        - git fetch origin $version

```

To:

```plaintext
        - git remote set-branches --add origin master
        - GIT_TRACE=1; GIT_CURL_VERBOSE=1 git pull --verbose
        - git fetch origin $version

```

Well, something like that should help get more detailed error information.

---

<div class="post-metadata">

### Author: ![craisp](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/craisp/32/119998_2.png) [@craisp](https://meta.discourse.org/u/craisp)
#### Post date: [2. Mai 2017 um 20:07 UTC](https://meta.discourse.org/t/failed-to-bootstrap-failure-with-receiving-network-data/61951/12 "2017-05-02T20:07:38Z")

</div>

Thank you very much for that detailed answer.

I was facing two issues, that had nothing to do with each other:

1. One of the network service providers of the Linode Datacenter was having trouble this morning, that was the problem with the rebuilding and the git pull commands.
2. I administrate the app for a non-profit organisation. They commissioned a domain transfer a week ago. I didn’t know, that the transfer was happening this morning, but it did 🙂  
And due to that, there was a certificate of the new domain name registrar which got into the way. It’s still not solved, because I don’t have the login information for the domain-configuration yet, but I’m pretty sure it has nothing to do with discourse.

Thank you all very much. I like this viral community on [meta.discourse.org](http://meta.discourse.org) a lot 😍

---

<div class="post-metadata">

### Author: ![JammyDodger](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/jammydodger/32/254611_2.png) [@JammyDodger](https://meta.discourse.org/u/JammyDodger)
#### Post date: [8. Juni 2024 um 12:44 UTC](https://meta.discourse.org/t/failed-to-bootstrap-failure-with-receiving-network-data/61951/13 "2024-06-08T12:44:54Z")

</div>

Dieses Thema wurde nach 2594 Tagen automatisch geschlossen. Neue Antworten sind nicht mehr möglich.
