Failed to bootstrap HTTP request failed


(Jonathan Feist) #1

Continuing the discussion from Local docker install failed to bootstrap: HTTP request failed (not a yaml parsing error):

Still not working and I’ve checked status.github.com (All systems operational).

user@host:/var/docker$ sudo ./launcher bootstrap app
WARNING: No swap limit support
Calculated ENV: ...*yaml stuff omitted*...
cd /pups && git pull && /pups/bin/pups --stdin
error: couldn't connect to host while accessing https://github.com/SamSaffron/pups.git/info/refs
fatal: HTTP request failed
*long-string-IDK-if-safe2share-omitted*
FAILED TO BOOTSTRAP
user@host:/var/docker$ 

I’m not expecting anyone to know how to help me but I will add more if/when I figure out what I’ve done wrong.


(Jeff Atwood) #2

Still looks like http connectivity issues. Is this server on Digital Ocean per our guide recommendation?


(Jonathan Feist) #3

I’m trying to install locally, actually. Already have a DigitalOcean docker
install working fine though.


(Fleadope) #4

I’m getting the same error, and have for days. I can install perfectly well on Digital Ocean, but locally, it fails every time. Virtually the same output.


(Jeff Atwood) #5

What is between you and github.com on that computer? Any proxies, firewalls, routers, anti-virus software…


(Jonathan Feist) #6

For me just the standard microsoft security essentials, a standard router, no proxies. I’m pretty sure that I can git pull and push from other projects but I haven’t tested that and at the moment I’m in windows.

Edit: woops, no firewall on my lubuntu install that I know of and no anti-virus. (Confused myself into thinking about what’s installed on the windows OS because I was booted into that at the time - but yeah no firewall or proxies and a standard router)


(Fleadope) #7

Same for me, but i’m running Ubuntu 14.04. I can easily pull a GitHub repo, or a docker image.


(Jonathan Feist) #8

Well yes, I’m on Lubuntu 14.04 64-bit. Just at the time of writing I was on dual-booted windows OS. And I can clone from Github just fine.


(Fleadope) #9

There was no action here for quite a while, but I solved my issue and thought I’d at least reply to myself so this can be closed. (This response comes up in google for various search terms, as I found when trying to solve the issue)

Not sure I can reproduce the steps here, or that they would be generally applicable, but at the end of the day, the problem was that I had iptables rules blocking the docker container from connecting to the internet.


(Jonathan Feist) #10

Can you elaborate on what you did to fix it and/or any resources you used? That would be great, thanks mate.


(Kane York) #11

I assume it would be to inspect your iptables -L and ensure you don’t have any conflicting rules.


(Fleadope) #12

That’s pretty much it - any specifics in my case probably wouldn’t apply to your box.


(Kane York) #13

This topic was automatically closed after 2 days. New replies are no longer allowed.