# 启动失败 - 启动器重建应用

**URL:** https://meta.discourse.org/t/failed-to-bootstrap-launcher-rebuild-app/110619
**Category:** Self-hosting
**Created:** [2019年三月4日 13:53 UTC](https://meta.discourse.org/t/failed-to-bootstrap-launcher-rebuild-app/110619 "2019-03-04T13:53:42Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![TestUser](https://avatars.discourse-cdn.com/v4/letter/t/e495f1/32.png) [@TestUser](https://meta.discourse.org/u/TestUser)
#### Post date: [2019年三月4日 13:53 UTC](https://meta.discourse.org/t/failed-to-bootstrap-launcher-rebuild-app/110619/1 "2019-03-04T13:53:42Z")

</div>

I have updated the URL `http://example.com` to `http://example.com/forum`. After run the `./launcher rebuild app`. I got below error message. How to resolve this issue :(.

```
FAILED
--------------------
Errno::ENOENT: No such file or directory @ rb_sysopen - /etc/apache2/sites-available/example.conf
Location of failure: /pups/lib/pups/replace_command.rb:8:in `read'
replace failed with the params {"global"=>true, "filename"=>"/etc/apache2/sites-available/example.conf", "from"=>"proxy_pass http://example.com;", "to"=>"rewrite ^/(.*)$ /forum/$1 break;\nproxy_pass http://example.com;\n"}
31f29f6fcf0f81a0558e1ca54746ea217d061439a403815c0ba2e5adf304fe37
**FAILED TO BOOTSTRAP** please scroll up and look for earlier error messages, there may be more than one

```

---

<div class="post-metadata">

### Author: ![zogstrip](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/zogstrip/32/512781_2.png) [@zogstrip](https://meta.discourse.org/u/zogstrip)
#### Post date: [2019年三月4日 17:22 UTC](https://meta.discourse.org/t/failed-to-bootstrap-launcher-rebuild-app/110619/2 "2019-03-04T17:22:03Z")

</div>

Subfolder installs require much more work and configuration than domain/subdomain installs.

You might want to read these topics

> [@Serve Discourse from a subfolder (path prefix) instead of a subdomain](https://meta.discourse.org/t/subfolder-support-with-docker/30507):
>
> warning Discourse Official Statement about Subfolder setup We support subfolder setups for our hosted customers at the enterprise level and up. Due to heavy technical setup complexity we strongly recommend you do not use this setup unless you are very experienced in custom subfolder setups. It is critical you have a deep understanding of NGINX setup in the Discourse Docker container Secure original IP forwarding using custom headers in the proxy chain Rate limiting in front proxy server I…

> [@Use a subfolder (path prefix) to serve Discourse with multiple servers sharing a domain](https://meta.discourse.org/t/discourse-in-a-subfolder-multiple-servers-sharing-a-domain/30514):
>
> Let’s say you have a WordPress blog on http://=DOMAIN=, and you want to serve your Discourse forums (which run on a different server) from http://=DOMAIN==PATH=. How do you do that? Note: This won’t work for serving multiple Discourse instances from different folders on the same domain. You need to use different subdomains so that each site can have different cookies. You’re going to need to send all traffic for the domain to one place that can route traffic to the correct server. In thi…
