# Failed to bootstrap on first install

**URL:** https://meta.discourse.org/t/failed-to-bootstrap-on-first-install/295475
**Category:** Self-hosting
**Created:** [February 15, 2024, 12:44pm UTC](https://meta.discourse.org/t/failed-to-bootstrap-on-first-install/295475 "2024-02-15T12:44:19Z")
**Posts on this page:** 1
**Showing post:** 16

<div class="post-metadata">

### Author: ![Ed\_S](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/ed_s/32/134015_2.png) [@Ed\_S](https://meta.discourse.org/u/Ed_S)
#### Post date: [February 16, 2024, 9:56am UTC](https://meta.discourse.org/t/failed-to-bootstrap-on-first-install/295475/16 "2024-02-16T09:56:10Z")

</div>

Thanks for all the responses and extra detail.

Indeed, the search for OOM and similar would probably be useful before a reboot, not after. So yes please repeat, if you have not yet rebooted.

Running  
`vmstat 5`  
concurrently, in a second connection, as the rebuild hits the critical section, could be informative.

But really I have only two hypotheses

- shortage of memory which might cause slow progress or might cause something to be terminated
- running out of time because of slow progress

It is a pity your provider does not allow both increases and decreases of RAM.

It is true that initial installation, and subsequent updates which require rebuilds every month or two, require more memory than previously. But  
memory=RAM+swap  
so adding swap should be successful, provided there is no time pressure.

You have lots of disk. I recommend you add a second and a third swapfile. See the instructions here, modified to make new files

> [@Create a swapfile for your Linux server](https://meta.discourse.org/t/create-a-swapfile-for-your-linux-server/13880/1):
>
> - Create an empty swapfile
> 
> ```plaintext
> install -o root -g root -m 0600 /dev/null /swapfile
> 
> ```
> 
> - write out a 2GB file named ‘swapfile’
> 
> ```plaintext
> dd if=/dev/zero of=/swapfile bs=1k count=2048k
> 
> ```
> 
> - tell linux this is the swap file:
> 
> ```plaintext
> mkswap /swapfile
> 
> ```
> 
> - Activate it
> 
> ```plaintext
> swapon /swapfile
> 
> ```
> 
> - Add it to the file system table so its there after reboot:
> 
> ```plaintext
> echo "/swapfile swap swap auto 0 0" | tee -a /etc/fstab
> 
> ```

You already have /swapfile so run these commands with /swapfile.1 and /swapfile.2 instead

Afterwards  
`swapon`  
should show three files in use, or ready for use, and  
`free`  
should show about 2G RAM and about 6G of swap

Then try again!

Edit: I notice my 1G RAM instance has  
` db_shared_buffers: "128MB"`  
in the app.yml

Be very careful when modifying app.yml - do not add or remove spaces!

---

_[View the full topic](https://meta.discourse.org/t/failed-to-bootstrap-on-first-install/295475)._
