# נכשל באתחול בהתקנה ראשונה

**URL:** https://meta.discourse.org/t/failed-to-bootstrap-on-first-install/295475
**Category:** Self-hosting
**Created:** [15 בפברואר,‏ 2024,‏ 12:44pm UTC](https://meta.discourse.org/t/failed-to-bootstrap-on-first-install/295475 "2024-02-15T12:44:19Z")
**Posts on this page:** 1
**Showing post:** 6

<div class="post-metadata">

### Author: ![Ed\_S](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/ed_s/32/134015_2.png) [@Ed\_S](https://meta.discourse.org/u/Ed_S)
#### Post date: [15 בפברואר,‏ 2024,‏ 4:02pm UTC](https://meta.discourse.org/t/failed-to-bootstrap-on-first-install/295475/6 "2024-02-15T16:02:39Z")

</div>

Thanks for all the details. It’s good that you did this

> [@tumbleweed](#):
>
> `sysctl vm.overcommit_memory=1`

but I think probably doing that will only last until the next reboot. After reboot you would need to do it again. See [MKJ’s Opinionated Discourse Deployment Configuration](https://meta.discourse.org/t/mkjs-opinionated-discourse-deployment-configuration/193355) for tips on making this permanent.

It feels possible that you have too little memory (by which I mean RAM+swap) and yet 2+4 should be enough. Please run the following quick diagnostics and post the results:

```plaintext
cat /etc/lsb-release
uptime
df -h /
free
swapon
vmstat 5 5
dmesg|egrep -i "memory|oom|kill"
ps auxrc

```

Please also share your app.yml file here - but not the passwords and secret tokens inside it!

If you are able to set up two ssh connections, you can use one to run an app rebuild and use the other to see what the machine is doing. I like to alternate

```plaintext
vmstat 5 5
ps auxrc

```

It’s possible you are swapping to a remote disk - a network-attached storage - and this is known to be a problem. It will be very slow. Perhaps it causes a timeout and this is the problem. Perhaps there’s a way to adjust the timeout.

I found [this](https://postgrespro.com/list/thread-id/2406057) - maybe it helps?

> (The default systemd timeout is 90 seconds, at least in some releases of systemd, so this fits quite nicely).
> 
> You could try to work around this by increasing TimeoutStartSec in postgresql’s systemd unit (or even globally), which perhaps only hides the problem until the next service suddenly doesn’t start anymore.

Edit: if so, then [this advice](https://unix.stackexchange.com/a/310155) might be good:

> You can uncomment in `/etc/systemd/system.conf` the lines:
> 
> ```plaintext
> DefaultTimeoutStartSec=90s
> DefaultTimeoutStopSec=90s
> 
> ```
> 
> And change the value to what you consider appropriate.

---

_[View the full topic](https://meta.discourse.org/t/failed-to-bootstrap-on-first-install/295475)._
