# Failed to bootstrap (/tmp/add-cloudflare-ips)

**URL:** <https://meta.discourse.org/t/failed-to-bootstrap-tmp-add-cloudflare-ips/221667>\
**Category:** Self-hosting\
**Created:** [March 22, 2022, 4:15pm UTC](https://meta.discourse.org/t/failed-to-bootstrap-tmp-add-cloudflare-ips/221667 "2022-03-22T16:15:45Z")\
**Posts on this page:** 1\
**Showing post:** 20

<div class="post-metadata">

**Author:** ![supermathie](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/supermathie/32/507518_2.png) [@supermathie](https://meta.discourse.org/u/supermathie)\
**Post date:** [March 22, 2022, 7:12pm UTC](https://meta.discourse.org/t/failed-to-bootstrap-tmp-add-cloudflare-ips/221667/20 "2022-03-22T19:12:48Z")

</div>

Try copying the existing `cloudflare.template.yml` to `cloudflare-static.template.yml` and replace the top part to make it look like:

```plaintext
run:
  - file:
      path: /tmp/add-cloudflare-ips
      chmod: +x
      contents: |
        #!/bin/bash -e
        cat <<EOF > /tmp/cloudflare-ips
        173.245.48.0/20
        103.21.244.0/22
        103.22.200.0/22
        103.31.4.0/22
        141.101.64.0/18
        108.162.192.0/18
        190.93.240.0/20
        188.114.96.0/20
        197.234.240.0/22
        198.41.128.0/17
        162.158.0.0/15
        104.16.0.0/13
        104.24.0.0/14
        172.64.0.0/13
        131.0.72.0/22
        2400:cb00::/32
        2606:4700::/32
        2803:f800::/32
        2405:b500::/32
        2405:8100::/32
        2a06:98c0::/29
        2c0f:f248::/32
        EOF
        # Make into nginx commands and escape for inclusion into sed append command
        CONTENTS=$(</tmp/cloudflare-ips sed '/^$/d; s/^.*/set_real_ip_from &;/' | tr '\n' '\\' | sed 's/\\/\\n/g')
        
        echo CloudFlare IPs:
        echo $(echo | sed "/^/a $CONTENTS")
        # Insert into discourse.conf
        sed -i "/sendfile on;/a $CONTENTS\nreal_ip_header CF-Connecting-IP;" /etc/nginx/conf.d/discourse.conf
        # Clean up
        rm /tmp/cloudflare-ips

  - exec: "/tmp/add-cloudflare-ips"
  - exec: "rm /tmp/add-cloudflare-ips"

```

Then change your app container to use the `-static` template instead of the original one.

Don’t leave it like that forever.

---

_[View the full topic](https://meta.discourse.org/t/failed-to-bootstrap-tmp-add-cloudflare-ips/221667)._
