# Failed to Bootstrap with "postgres already running"

**URL:** https://meta.discourse.org/t/failed-to-bootstrap-with-postgres-already-running/118225
**Category:** Self-hosting
**Created:** [May 20, 2019, 3:47pm UTC](https://meta.discourse.org/t/failed-to-bootstrap-with-postgres-already-running/118225 "2019-05-20T15:47:47Z")
**Posts on this page:** 6
**Page:** 1

<div class="post-metadata">

### Author: ![davidkingham](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/davidkingham/32/119528_2.png) [@davidkingham](https://meta.discourse.org/u/davidkingham)
#### Post date: [May 20, 2019, 3:47pm UTC](https://meta.discourse.org/t/failed-to-bootstrap-with-postgres-already-running/118225/1 "2019-05-20T15:47:47Z")

</div>

This morning I tried to turn a plugin back on (moderator plugin) and got the following error when rebuilding the app. I then disabled the plugin and rebuilt again to only get the same error. I also tried disabling all the plugins. Any other ideas? This is on my sandbox so it’s not critical. It was working fine prior to this and I didn’t make any other changes besides a git pull.

```plaintext
FAILED
--------------------
Pups::ExecError: socat /dev/null UNIX-CONNECT:/shared/postgres_run/.s.PGSQL.5432 || exit 0 && echo postgres already running stop container ; exit 1 failed with return #<Process::Status: pid 44 exit 1>
Location of failure: /pups/lib/pups/exec_command.rb:112:in `spawn'
exec failed with the params "socat /dev/null UNIX-CONNECT:/shared/postgres_run/.s.PGSQL.5432 || exit 0 && echo postgres already running stop container ; exit 1"
740f79002f403805b363a73f114aef7a2075556ac205778eb27e2d63f2c0fe74
**FAILED TO BOOTSTRAP** please scroll up and look for earlier error messages, there may be more than one

```

---

<div class="post-metadata">

### Author: ![merefield](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/merefield/32/176214_2.png) [@merefield](https://meta.discourse.org/u/merefield)
#### Post date: [May 20, 2019, 3:54pm UTC](https://meta.discourse.org/t/failed-to-bootstrap-with-postgres-already-running/118225/2 "2019-05-20T15:54:08Z")

</div>

Looks like it’s trying to spawn a new process when there is already one running?

Try a reboot?:

`sudo shutdown -r now`

---

<div class="post-metadata">

### Author: ![davidkingham](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/davidkingham/32/119528_2.png) [@davidkingham](https://meta.discourse.org/u/davidkingham)
#### Post date: [May 20, 2019, 4:15pm UTC](https://meta.discourse.org/t/failed-to-bootstrap-with-postgres-already-running/118225/3 "2019-05-20T16:15:46Z")

</div>

Silly me. Thanks merefield!

---

<div class="post-metadata">

### Author: ![TheBestPessimist](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/thebestpessimist/32/247704_2.png) [@TheBestPessimist](https://meta.discourse.org/u/TheBestPessimist)
#### Post date: [May 21, 2019, 5:11am UTC](https://meta.discourse.org/t/failed-to-bootstrap-with-postgres-already-running/118225/4 "2019-05-21T05:11:39Z")

</div>

Curiosity: does `sudo reboot` command do the same thing as `sudo shutdown -r now`? ( i always used `reboot` on linux, only used `shutdown -r -t 0` in windows :D)

---

<div class="post-metadata">

### Author: ![merefield](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/merefield/32/176214_2.png) [@merefield](https://meta.discourse.org/u/merefield)
#### Post date: [May 21, 2019, 5:49am UTC](https://meta.discourse.org/t/failed-to-bootstrap-with-postgres-already-running/118225/5 "2019-05-21T05:49:55Z")

</div>

Suspect they do the same thing under the hood (switching run levels) but don’t quote me on it!

---

<div class="post-metadata">

### Author: ![system](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/system/32/443519_2.png) [@system](https://meta.discourse.org/u/system)
#### Post date: [June 20, 2019, 5:49am UTC](https://meta.discourse.org/t/failed-to-bootstrap-with-postgres-already-running/118225/6 "2019-06-20T05:49:57Z")

</div>

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.
