Failed to launch discourse


(Najam Sikander) #1

i am following GitHub - discourse/discourse: A platform for community discussion. Free, open, simple. to setup discourse on my laptop for testing.
Vagrant up works and when I am running bundle exec rails s it started a console showing whats in progress and after notifying me about rendering of few views it got stuck while browser is loading for ages.


(Najam Sikander) #2

console information where its stuck now is following

I, [2015-01-11T09:13:19.277760 #2828]  INFO -- :   Rendered list/list.erb within layouts/application (6.8ms)
I, [2015-01-11T09:13:19.420692 #2828]  INFO -- :   Rendered common/_special_font_face.html.erb (29.6ms)
D, [2015-01-11T09:13:19.489817 #2828] DEBUG -- :   ColorScheme Load (8.3ms)  SELECT  "color_schemes".* FROM "color_schemes"  WHERE "color_schemes"."versioned_id" IS NULL AND "color_schemes"."enabled" = 't' LIMIT 1
D, [2015-01-11T09:13:19.520691 #2828] DEBUG -- :    (16.4ms)  SELECT  "categories"."updated_at" FROM "categories"   ORDER BY updated_at desc LIMIT 1
I, [2015-01-11T09:13:20.349077 #2828]  INFO -- :   Rendered common/_discourse_stylesheet.html.erb (870.0ms)
I, [2015-01-11T09:13:20.361264 #2828]  INFO -- :   Rendered layouts/_head.html.erb (1015.8ms)
I, [2015-01-11T09:13:35.384748 #2828]  INFO -- :   Rendered common/_discourse_javascript.html.erb (24.8ms)
I, [2015-01-11T09:13:35.398233 #2828]  INFO -- : Completed 200 OK in 16633ms (Views: 16197.3ms | ActiveRecord: 108.8ms)

(Mittineague) #3

Let me guess, Windows?

If so, go for a walk, get something to eat etc. and check back in an hour.

On a more positive note, once it’s loaded the wait time is much less.

This has been discussed elsewhere, maybe if you try a Search here you’ll have better luck than I finding results.

EDIT
here it is


(Khoa Nguyen) #4

Look familiar :


(Najam Sikander) #5

yes its windows and I have been waiting for 2 hours now. I guess i should sleep and check in morning :smile:


(Mittineague) #6

It has never taken that long for me. Usually ~40 minutes. Which is painfully slow, but at 2 hours maybe it has indeed hung.

Are you sure there aren’t any errors or warnings in the CLI?

Even if not it might be worth backing out and trying again.

Did you follow these?

vagrant up
vagrant ssh
bundle install
bundle exec rake db:migrate
bundle exec rails s

(Khoa Nguyen) #7

Really? Each request or only on bootstrap?


(Mittineague) #8

Only the first load, not every request. It seems the bottleneck is vagrant putting everything into memory. Once there it doesn’t take near as long.


(Najam Sikander) #9

yes all this :slight_smile: just watched Annabelle and page is still loading :slight_smile:


(Khoa Nguyen) #10

Yeah. Thanks for your information. I’ll watch something and wait


(Najam Sikander) #11

currently console showing following lines

I, [2015-01-11T11:02:53.390630 #2828]  INFO -- :   Rendered common/_discourse_stylesheet.html.erb (998.0ms)
I, [2015-01-11T11:02:53.401092 #2828]  INFO -- :   Rendered layouts/_head.html.erb (1150.2ms)
I, [2015-01-11T11:03:10.164110 #2828]  INFO -- :   Rendered common/_discourse_javascript.html.erb (24.6ms)
I, [2015-01-11T11:03:10.176479 #2828]  INFO -- : Completed 200 OK in 18567ms (Views: 18073.9ms | ActiveRecord: 200.8ms)

(Khoa Nguyen) #12

Your hardware specs?


(Khoa Nguyen) #13

Always this completed 200 OK but nothing show.


(Najam Sikander) #14

Have at-least two movies now watching “The Imitation Game” maybe i will figure out something while watching this movie


(Najam Sikander) #15

how can i change location of VMDK file from C:\Users\najam.sikander\VirtualBox VMs\discourse_default_1420967878382_65768\box-disk1.vmdk to some other drive?


(Khoa Nguyen) #16

yay

@najam you can setting in virtualbox and delete old image


(Najam Sikander) #17

I already change to different drive now waiting for Vagrant up command to finish its work lets see.


(Najam Sikander) #18

intel i7 2.40ghz, 8gb ram


(Najam Sikander) #19

how long you waited before your browser show UI?


(Khoa Nguyen) #20

about 30 minutes. but very slow when navigate

Drive ? You should use diffrent hardware drive. Or just use linux